I found an old Macbook Pro, OS X 10.6.8. Little did I know that there was an evil little metaphorical man malevolently cackling and taunting SO ?&#%ING HARD inside the mystery mac of horrors:

Attempt #:

  1. Tried to just stick in a USB with Chalet OS. unsuccessful.
  2. I stuck in an Ubuntu CD for latter use (this is relevant to #4). Succes-ish!
  3. I attempted to login. Don't know my password. unsuccessful!
  4. I took the CD out, and used the Options key to get into the boot menu. When I tried to put the CD back in, the computer (sensing that I was trying to install a non-mac OS) thwarted my attempts by making the disk drive suffer from an inexplicable mechanical breakdown. Raged at the computer, I (asininely) shoved the CD into the disk drive to no avail. VERY Unsuccessful
  5. Attempted to boot up internet recovery. Unsuccessful! I latter learn that the computer has a sufficient OS version, but is somehow missing only this one single firmware update!
  6. Attempted to boot into offline recovery mode. Unsuccessful! The recovery partition is missing.
  7. Reset the PRAM and SMC. No change. Unsuccessful!
  8. Shift-booted into safe mode. No change. UNSUCCESSFUL!
  9. Attempted to reset Admin Password (according to here). Somehow, /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist is inexplicable missing from the system. I try several other things in single user mode, but am block out because of 'insufficient permissions' on things that I should have permission to. Except that I was able to discover that I am using a 32-bit OS.
  10. I attempted to factory reset the mac using a pirated version of the mac os operating system. I downloaded A DMG file that I loaded onto a flash drive using transmac & diskpart.It did show up in the boot menu, however apparently failed to boot, instead showing a folder with a question mark.
  11. Using my jeweler's kit, I disassembled my mac, and attempted to fix the CD drive. Successful?
  12. Booting up the mangled Ubuntu Disk I retrieved from the Disk Drive in #11 (titled 'Windows 7 Install' (WTF?) in the boot menu) by pressing the Options key showed the following error message:


 Select CD-ROM Boot Type:
  1. Ecstaticly thinking that I had made progress, I attempted to put Chalet OS onto a disk, and boot it up. UNSUCCESSFUL!
  2. Then, I did some research on it which turned up this. Ecstatic even more so at the thought of a faster 64-bit operating system, I attempted to ascertain if the processor was 64-bit. The Mac, sensing that my spirits were lifted, then made the single user mode terminal inaccessible (I couldn't find ANYTHING on the internet about this bizarre new problem): I press Command + V, the terminal comes up, it starts loading, then abruptly stops and the Mac OS then continues loading normally. After more research, I attempted the article above. When I plopped in the trans 64-bit-on-32-bit-EFI install, the Mac didn't recognize it. UNSUCCESSFUL!
  3. Scared and worried, I plopped in the other Ubuntu CD (the one that successfully showed an error message earlier): no response even after PRAM and SMC were reset.
  4. Frustrated, ready to give up, and unable to sleep at night at the thought that the computer is going to jump up and murder/beat/other me in my sleep, I headed here to Super User.

In conclusion, I was trying to get Chalet OS installed on a mac because i've grown up around windows and I'm more used to a windowsy-feel. Now, I am faced with a Mac that is capable of baiting, tormenting, and frustrating me to depths I never knew existed. And, I'll give anything just to get something to work on it (any linux will do). Also, this is the only Mac in my house, so I'm forced to use windows software to tame this rabid beast of a Mac.

  • First you need to figure out exactly which model of MacBook Pro you have, and exactly which OS X version it's running. You said 10.8.6, which never existed. Maybe you meant 10.6.8? You linked to a firmware update for the 2011 model in one place, but you linked to instructions for a 2006 model in another place. You said you're running a 32-bit version of OS X, which 10.8.x was not. In contrast, 10.6.8 did still support the old 32-bit x86 machines from 2006 (2007 and newer Macs are all x86_64). Try the password reset instructions for 10.6 and earlier (skip the launchctl/opendirectoryd step).
    – Spiff
    Jul 15, 2017 at 1:43
  • Another approach might be to make a GPT-formatted flash drive set up with ChaletOS. x86 Macs' EFI bootROM can't boot from drives that only have an MBR on them. They must have a GPT (they can have a legacy MBR or protective MBR in addition to GPT, but they need a GPT) for the Mac to boot from them.
    – Spiff
    Jul 15, 2017 at 1:45
  • Also, please be patient with your 11-year-old Core Duo (not even Core 2 Duo) MacBook Pro. Remember it was built in a time when Windows XP was the best Microsoft could do, and Vista hadn't even been released yet. Most 11-year-old PC laptops probably haven't held up as well.
    – Spiff
    Jul 15, 2017 at 1:50
  • @Spiff I did use diskpart for converting it to GPT (as my research turned up). Also, keep in mind that this 11 year old malevolent piece of $&%!, I mean hardware, has been sitting in my basement for 11 years, and yet it still workz, so why not use it instead of sending it to a museum? Also, as I have stated above, there no longed exists the ability for me to retry the instructions skipping the launchctl/opendirectory step because the malevolent mac took away single-user-mode privileges (I feel like a kid who's being bossed around by an adult Mac).
    – Jack G
    Jul 15, 2017 at 2:24
  • 1
    Cmd-V is verbose boot which does exactly as you've described. Cmd-S is single user mode.
    – Spiff
    Jul 15, 2017 at 6:25


You must log in to answer this question.

Browse other questions tagged .