4

The clock in the taskbar keeps disappearing, there is just a blank space as shown. Clicking the space brings up the small calendar as shown, so I know the clock is still there, it's just not displaying:

enter image description here

It happens when my computer wakes up from suspend.

I can always get the clock back by restarting Windows Explorer in the Task Manager manually.

It's a fresh install of Windows 10. Is there some way to fix this? In worst case, would it be possible to schedule a task each time the computer woke up to restart Windows Explorer?

  • Similar issue: answers.microsoft.com/en-us/windows/forum/windows_10-start/…. Check your W10 version & try perform clean boot first, then examine running apps before & during reproduce the issue by putting PC into sleep mode & waking it up again. – Tetsuya Yamamoto Jul 17 '17 at 8:01
  • I have tried everything in that post above. Did not help. I talked to someone at Microsoft who walked me through doing an in place reinstall of windows (windows was reinstalled but I didn't lose any installed apps or data). STILL the clock disappears. It seems to go and come back in fact. Sometimes if I just leave the computer running after it wakes back up, several hours or maybe a day later the clock reappears. Maybe windows explorer crashes and restarts which brings the clock back. – Michael Grant Jul 23 '17 at 11:38
  • A few more days of experimentation to try and understand why this is occurring. I use Chrome with multiple accounts. Chrome super-imposes a little photo of my profile picture in the task bar tab associated with that account. When I restart Windows Explorer, those little photos go away and only the generic Chrome icon remains in the task bar. However, if I just wait a while, the clock comes back on it's own (sometimes a few hours, sometimes a day!), in this case, Chrome tabs still have the picture of me, so I don't think Windows Explorer is restarting. – Michael Grant Jul 26 '17 at 9:58
-1

Have same problem and found going to taskbar settings and turning off and then back on "automatically hide taskbar in desktop mode" will get the clock back. But wish it wouldn't happen in the first place.

protected by Community Oct 27 '17 at 5:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.