1

The question may sound obvious, but I cannot connect to open TCP port on Windows 10 Home on my home network.

My devices: PC1 - Windows 10 Home (with Ubuntu 14 installed as a second OS) PC2 - Windows 8.1

To test connectivity, I do the following: - run "python -m SimpleHTTPServer" on PC1 (this opens local HTTP server on port 8000 to browse filesystem) - open http://[PC1 ip]:8000/ on PC1 - works as expected. - connect PC2 to the same local WiFi network. - open http://[PC2 ip]:8000/ on PC2 - connection timeout.

I have tried different things to troubleshoot: - added wifi network to "private" on both PC1 and PC2 - turned off the firewall on both PC1 and PC2 - turned on the firewall on PC1 with the rule "allow inbound connections on port 8000" - turned off Windows Defender on both PC1 and PC2 - disabled (and then uninstalled) antivirus on PC1

PING does not work in either direction, too. From PC2, Wireshark shows SYN attempts to PC1 with no response. Though I see ARP packets go here and there and IP address resolves to MAC correctly.

If I run Ubuntu on PC1, everything works perfectly. I wonder if there any kind of limitation on "Home" edition of Windows that disallows inbound TCP connects?

  • 1
    netstat -abn -proto tcp in an elevated cmd to check that you are actually listening on the correct IP address (either your local network address or 0.0.0.0 should work; 127.0.0.1 won't). – Bob Jul 17 '17 at 0:38
  • thank you for your response, I do see listening on 0.0.0.0. But still, cannot connect. – AlexB Aug 22 '17 at 3:18
  • When you say you uninstalled antivirus - what software were you using? It's common for antivirus programs to silently drop all incoming connection attempts. Can you try turning off Windows Firewall entirely, just to test? – Bob Aug 22 '17 at 3:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.