5

Microsoft Word 2010

When I try to open existing word document, I am getting following error:

enter image description here

To open this document, I then have to click on Properties and click on "Unlock" button. Once I do that, it opens the file.

enter image description here

But this I have to do for all files. I want a solution which removes this error completely.

Thanks!

  • How did you try to open them? That block is (usually) caused by downloading the file from the internet. Using another Browser than IE/Edge might be able to prevent it. Alternatively you could also use a script to mass remove the flag or there might be options within Word. – Seth Jul 17 '17 at 5:56
  • If your Word files are in same directory & you want to unlock all of them, you can utilize Powershell & execute this command: dir [path_to_directory] -Recurse | Unblock-File, or consider read this post: superuser.com/questions/38476/…. – Tetsuya Yamamoto Jul 17 '17 at 6:13
3
  1. You will need to change this setting in Group Policy Editor

  2. Click on Start Menu and type gpedit.msc and hit Enter

  3. Go to User Configuration > Administrative Templates > Attachment Manager
  4. In the window pane on the right, find Do not preserve zone information in file attachments and double click it
  5. Select the Enabled radio button and then hit OK to exit out of that window
  6. Reboot your computer or log off Windows and log back in for changes to take effect

Edit: If you have Windows 7 Home Premium, you do not have the option to open gpedit.msc and will need to make changes to the registry. Do the following:

  1. Click the Start Menu and type regedit and hit Enter

  2. Go to HKEY_CURRENT_USER > Software > Microsoft > Windows > CurrentVersion > Policies > Attachments

  3. With Attachments selected look in the right window pane for a DWORD Value called SaveZoneInformation, double-click it and enter a value of 1 (if the Attachments key does not exist, and there's a good chance it won't, go to the next step).

    3a. If you do not see the Attachments key in Policies, do the following: right-click on Policies and select New and then select Key. Name this key Attachments. Now right-click on Attachments and select New and then select DWORD (32-bit) Value. Name this value SaveZoneInformation. Now double-click SaveZoneInformation and set its value to 1.

  4. Now reboot your PC or log off Windows and log back in for the change to take effect.

^^The above setting change will only affect any new files added to your PC going forward.

If you want to remove this attribute for the files already on your PC, I'd suggest the following:

  1. Move all the files you would like to remove this attribute from into one folder location. Doesn't matter where.
  2. Open Microsoft Word
  3. Go to File > Options > Trust Center
  4. Click on Trust Center Settings
  5. Click on Trusted Locations
  6. Click on Add new location
  7. Now select the folder where you had moved all your files into
  8. Click on OK twice to close out both windows and you're done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.