0

I love Clonezilla. I have been using it to make an exact copy of my laptop's 1TB-hard drive into a 1TB-external USB drive. It worked perfectly for for a few years.

But now I bought another 1TB, external USB drive (Seagate expansion) and Clonezilla does not let me make the back up because... the USB disk has one less sector!!!???

I you can not believe it (as I couldn't at first), I attach (link) a screen capture.

https://www.dropbox.com/s/k4bwa492210duh3/clonezilla.jpg?dl=0

I tried not to copy the boot loader (which is around 400 bytes anyway) but didn't work. Also tried formatting the USB disk with different options, no success.

What can I do? Please! I bought the USB disk only for this purpose, if it doesn't work then the disk is somewhat useless... Or it is just bad luck? :(

By the way I didn't find /var/log/clonezilla.log to show you. I'm using linux mint.

1

Clonezilla by default only clones to disks with equal or higher size even if there's enough disk space. To get it working you need to ensure that the size of your partitions + partition table + MBR is lower that the the size of your backup disk and then you should be able to clone by checking the "-icds" option (ONLY USE THIS OPTION IN PARTITION BY PARTITION MODE AND NOT IN SECTOR BY SECTOR MODE AND ONLY AFTER YOU ENSURED THAT THERE IS ENOUGH SPACE!!!) in the advanced extra parameters menu which will skip the disk size check.

The reason why some hard drives have more sectors than others:

A 1 TB disk normally can't be exactly 1 TB big and so it is normal that none identical disks have different sizes.That is caused by the fact that KB, MB, GB, ... are using SI (International System of Units) prefixes (K, M, G, ...) which are using a base of 10 so K = 1000, M = 1000000, G = 1000000000, ... but computers are based on the binary system and so normally numbers like sizes are a multiple of 2 (1 KiB = 1024 B, 1 MiB = 1048576 B, ...).Now the problem is that it is not possible to create a 1 TB hard drive because the size of a sector is a multiple of 2 and not 10 and so some manufactures round up and some round down and so one disk has one sector more than the other one.

| improve this answer | |
  • I'm sorry your answer doesn't make much sense... If I want to back up 1TB of data, of course I need at least 1TB of space. (and what do you mean by "even if there's enough disk space"??) – terauser Jul 21 '17 at 13:37
  • the point is, both disks (source and destination) are 1TB, but one has one more sector than the other. So, it seems not all 1TB disks are created equal.. – terauser Jul 21 '17 at 13:38
  • 1
    You normally don't need to backup 1 TB because there's always at least one sector free on some partition...but even if your hole disk is empty clonezilla won't clone to a disk with less space except you force it by using the "-icds" option.I edited my answer to include a explanation why one disk has one sector more that the other one. – testeaxeax Jul 21 '17 at 14:18
  • nullterminatedstring, thanks for the clarification, your answer is very clear now. I tried your suggestion but unfortunately didn't work :( Meanwhile I just replaced the disk with a bigger one.. – terauser Jul 27 '17 at 12:19
  • @terauser Have you resized and maybe moved your partitions properly so that at the end of your disk was some space unallocated? – testeaxeax Jul 27 '17 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.