4

I came across this days upon a frustrating problem. Whenever I turn on the WiFi, my Bluetooth stops working properly. For example, I have a Bluetooth mouse, if I turn on the WiFi (not connecting to any wireless access points, even when I turned off every single WiFi capable device with which might interfere) my cursor just freezes and becomes unresponsive. After I turn off the WiFi, my mouse starts working straight away. It applies to all kinds of Bluetooth connections, like different smartphones. Can't establish a connection with any Bluetooth capable device. It's weird, because I didn't have such problems before. Hope you can help me, I really don't know what to do. I tried updating drivers, install the drivers from my manufacturer's site, rebooting laptop, turning off and on the Bluetooth / WiFi. I have a Lenovo IdeaPad 100-15iBD, Windows 10 up-to-date

1
  • What did you change since it worked last?
    – testeaxeax
    Jul 18 '17 at 16:33
4

battled with this for quite a while before working it out. From what I understand the Bluetooth and WiFi are both on the same piece of hardware and after updating to Windows 10, I think they were both defaulting to the same antenna.

FIX: Move the WiFi to use the AUX antena rather than allow the auto selection, you can do this as follows

  • Right click start and select DEVEICE MANAGER

  • Open network adapters

  • Right click Realtek RTL87xxxx wireles LAN 802....

  • Choose properties

  • Advanced tab

  • Antena Diversity Selection

  • Move from Auto to AUX (if this doesn't work trying Main is probably worth a shot)

  • Reboot

If it works for a bit and then stops again, under the same area switch off low power usage under the power management tab.

1
  • This answer got me in the correct area. I didn't have an option for Diversity Selection. I changed Roaming Decision to 'Optimize Bandwidth' and this resolved my issue.
    – RBZ
    Oct 8 '19 at 15:01
4

I have had the same problem with a newly bought Bluetooth headphones and it was driving me crazy. My machine is a Dell XPS 9550, on Windows 10. I know it's different from yours, but since I couldn't find any good links online to solve my problem, I thought it's worth sharing it here for others to try it out.

As others have mentioned Bluetooth uses 2.4Ghz channels while WiFi can use both 2.4 and 5.0 Ghz channels. So, if they are both using the same frequency, they are bound to interfere. The solution is usually to connect to put WiFi on a 5 Ghz channel with your router, which I did, but it didn't solve the problem completely. I updated/rolled-back drivers for both Wireless and Bluetooth cards on my PC multiple times to no avail. This is till I found CF5's answer to this question. His suggestion didn't work for me, but I looked at other options and I found that there is one under the name Bluetooth Collaboration. As it turns out, with this option ON, the Wireless card uses Bluetooth capacities to make WiFi connection smoother. Disabling this option was what worked for me in the end, after a week full of frustration.

Note that I was already connected to a 5 Ghz connection and it was enough on it own. I would still get disconnected from the Internet every minute or so. Now, it's been over a day and I haven't had any WiFi connection issues anymore and my headphone is also working perfectly ever since.

Hope this will come handy for you and others.

2

Try disabling Bluetooth device in network adapters in Device manager (this won't deactivate Bluetooth as there are separate drivers for it). It should work then.

It worked for my Bluetooth headset with my 2.4Ghz Wi-Fi, I am now using both without any interruptions.

Attaching image below in case you have trouble finding it:

Device Manager Image

1
  • wow, thanks alot. this worked great for me. Apr 1 at 19:32
0

Bluetooth sends signals over a 2.4GHz radio frequency. This becomes tricky when other nearby devices are also using that frequency. Wi-Fi is perhaps the biggest and most problematic example, as are other Bluetooth receivers and devices, which can interfere with one another. That said, even microwaves can cause Bluetooth interference with your devices. So can 2.4GHz phones, wireless speakers, external monitors, baby monitors, and really any wireless device that uses Bluetooth technology. There are a few things you can try. For example, remove all barriers, this means no brick walls between you and your devices, and definitely no metal desks. Since bluetooth communicates on 2.4GHz, try changing your router channel to 5GHz, this will help a lot, but you need to make sure that your wi-fi devices all support 5GHz operation. Lastly, try moving closer to the router.

0

After all the research I made about this topic I found only one working solution:

The wifi channels won't give you permanent solution if you change them.

I bought a small bluetooth antena (usb dongle) for 10€ and then I switched off the internal bluetooth adapter. (Should be disabled in Device Manager).

The issue comes from the fact that Wifi and Bluetooth waves are recived by the laptop from the same anthena.

0

I found the solution for my XPS 17 9710. If I didn't use my MX2 mouse, MX3 mouse, or MX keys for a few seconds, there would be a delay.  There was no delay if I kept moving it around.

When I turned off my wi-fi, the delay disappeared.  Also, at my office, there wasn't a delay.  So there must be something about the connection between my Eero routers at home compared to my Comcast router at at the office.  Also, this doesn't happen with my Microsoft Surfacebook 15 so there must also be a conflict with the Killer Intel wi-fi with bluetooth.

After a lot of searching I found this solution.  See the link for images and the full answer: http://www.gabesvirtualworld.com/bluetooth-mouse-stuttering-in-windows-10/

The solution is in the device manager under bluetooth device and then the “Intel Wireless Bluetooth” device. Then go to properties, find the Power Management tab and disable it. That immediately solved it for me.

Thank you Gabe's Virtual World!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.