0

At some point during the last few weeks, I started getting this warning whenever I try to open any zip file on my desktop. Any help for getting rid of it once and for all will be appreciated. Thank you.

enter image description here

P.S. Unchecking the "Always ask before opening this file" checkbox is useless, because the same warning pops up the next time as well (except without the checkbox), as indicated in the second screenshot. Besides, I want to disable this warning for all zip files, not just this one.

enter image description here

1

A lot of this answer is highly speculative. I haven't yet spent much time experiencing (or handling) such an issue. So, hopefully some of this ends up being somewhat useful.

According to some of my published notes (I haven't yet verified this), this may be caused by "Attachment Manager". I suspect that using a Microsoft web browser may be related to this. (This might be one key reason I haven't encountered this much.)

If you right-click a Zip file, and modify the properties, there may be a checkbox that you can uncheck for an individual file. Of course, that method may be a bigger pain in the neck for a single use (but might be better off in the long term).

Another option may be to strip the file of NTFS alternate file streams, by copying the file to and from an SD card that doesn't use NTFS.

MS KB 883260 - Attachment Manager may have more useful information.

From a command line, perhaps use:
SETX SEE_MASK_NOZONECHECKS 1
Although, that might just be for a similar dialog box for executable files.

Perhaps also try:

REG QUERY "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" /V SEE_MASK_NOZONECHECKS

REG QUERY "HKCU\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" /V SEE_MASK_NOZONECHECKS

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" /V SEE_MASK_NOZONECHECKS /T REG_SZ /D 1

(That last command, in particular, probably requires UAC elevation. Maybe the earlier two REG commands do too. Maybe even the SETX command, to have an effect?) (The difference between HKCU and HKLM is likely HKCU being specific to the user logged in, while HKLM being machine-wide.)

Edit: I added this information:
It looks like HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations may have a REG_SZ named LowRiskFileTypes which lists file extensions. So if you adjust the list, you may be able to adjust behavior for just ZIP files, instead of taking an all-or-nothing approach that affects other file types. (This is based on information I found at: Forum about Open File Security Warning.)

2
  • 1
    Thanks for that. The last paragraph helped. For anyone else: 1) Go to Registry Editor (Start -> type regedit). 2) navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations. 3) If there's no REG_SZ called LowRiskFileTypes, then create it (Right-click -> New -> String Value). 4) Double-click on it and add zip; 5) Click OK, log off and log on. – Oleksiy Jul 19 '17 at 7:58
  • Edit: In Step 4) it should be .zip; – Oleksiy Jul 19 '17 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.