0

I am using the following registry settings on a Windows 10 Ent x64 LTSB 1607 system that are pushed via GPO. The policy applies fine, however the desired effect of automatically logging in does not work.  

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
DefaultUserName=xxxxx (reg_sz)
DefaultPassword=XxXxX (reg_sz)
DefaultDomainName=PleaseWork (reg_sz)
AutoAdminLogon=1 (reg_sz)
ForceAutoLogon=1 (reg_sz)
Delete AutoLogonCount

Restart Computer

The computers are domain-joined. This method worked fine in Windows 7 Ent x64 but is not working in Windows 10.

If I utilize the tool from Sysinternals (Autologon), I can get almost the same behavior that I had in Windows 7, with the exception that it only automatically logs in on a reboot.

If I click "Sign Out" it just goes back to the login prompt. Additionally, if the computer is Wireless only and using user authentication to WiFi before login, neither of the autologin methods work, whereas they did with Windows 7.

Any suggestions/solutions would be amazing

  • Any errors? Does it just not login? What happens when you reboot? – Cheesus Crust Jul 19 '17 at 20:39
  • No errors, just doesn't log in. Rebboting multiple times doesn't make a difference. Wireless clients it doesn't work at all, but the wireless clients I am setting up are user based authentication - which I believe is the issue with those. – xerxes2985 Jul 19 '17 at 21:43
  • Are you pushing these changes through the Computer Policies? (Instead of user policy) – Cheesus Crust Jul 19 '17 at 21:50
  • 1) Are you actually using the data PleaseWork for the DefaultDomainName value? Is that your actual domain name? 2) Anything logged in the Security event log?, 3) Also, note that the AutoAdminLogon functionality as enabled through the Registry has only ever worked after a system reboot. – Twisty Impersonator Jul 20 '17 at 3:18
  • 1
    So I figured out the issue. Thank you to all for your assistance. The issue that was causing the auto login to not work, was the attempt to authenticate to Wireless before logon. I changed the single sign on portion of the wireless profile to connect after login. Once I changed that, the auto logon using registry settings and GPO worked. – xerxes2985 Nov 4 '17 at 1:01
1

So I figured out the issue. Thank you to all for your assistance. The issue that was causing the auto login to not work, was the attempt to authenticate to Wireless before logon. I changed the single sign on portion of the wireless profile to connect after login. Once I changed that, the auto logon using registry settings and GPO worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.