4

I’m using my laptop with an external display. Windows 10 is configured to project only to the second screen (said external display). That is, when hitting WinP, the last option ("only second screen") is activated.

With that setup, I close the laptop’s lid cause I don’t need it to be open. However, when opening the lid, the display settings get reset and it only projects onto the first screen.

Why is it doing that? That is unexpected and not what I want. How do I disable this?

  • Did you ever get a solution to this? – Adam Diament Apr 10 '18 at 9:55
  • 2
    @AdamDiament Unfortunately, no, I didn’t. – kleinfreund Apr 10 '18 at 12:23
  • Hey man, what laptop do you have? Is it Dell? Cause I had not any problems with that on my Asus but I recently purchased Dell g5 and here we go ... – Ekonoval Feb 8 '19 at 17:08
2

I have a Dell G5 5587 with an NVIDIA and Intel video cards. It have an HDMI port where I plugged an external monitor.

Now the trick is, that the HDMI port seems to be shorcircuited to the NVIDIA card instead of passing through the Intel one, so when I close the monitor lid, the Intel card thinks that the last monitor attached to it have disconnected (which is weird as it should just disable it, and not disconnect!) and just disables itself nearly totally. The desktop then jumps totally from a dual monitor setup to a single one, and only NVIDIA manages the only monitor "left".

When the lid is opened, it reenables back itself and reconnects back the monitor. It seems like the system receives a "monitor connected" event, and it automatically reenables it.

I haven't found a way to stop this disconnect/reconnect event on lid open/close, as it seems to be (sadly) managed by the Intel Graphics driver itself. Why do I think so - because when replacing the Intel driver by a Generic Videoadapter Driver, this behaviour stops (although the integrated monitor doesn't switch off at all when the lid is closed, which isn't good too!).

This may be related to the DisplayPort specification (which was specifically patched for the NVIDIA cards, but wasn't for Intel ones) which indeed states that on the monitor disable it should be disconnected from the system.

Now, back to your exact problem, which is easier to workaround than mine.

Setting the monitors to "extend desktop" to both monitors, and then setting the external one as the "primary monitor" seems to persist the desktop on lid open/close on the external monitor. You still receive the "monitor connected" event, but because the internal monitor isn't treated as a primary one, it doesn't change your desktop, windows, etc, just automatically extends to it, and we don't really care about that, do we? =)

But in the unlucky case that it doesn't help, you have a similar 2 graphics card setup with the external monitor being hardwired to the NVIDIA card and you doesn't care about the Intel card at all, you can either switch the Intel Graphics off at all (this will disable the internal monitor as well) or replace its driver with a "Basic Videodriver" (with all the drawbacks as described above), and with this setup them as you see fit.

0

A possible solution is to change what the computer does when the lid is closed:

Right click on battery icon > Power options > Choose what closing the lid does > Do nothing (on battery or plugged in, depending on your setup).> Save changes.

This means that, effectively, your laptop won't be any different with the lid closed or open.

  • This is not correct. The question is about what happens when the lid gets opened, not closed. This doesn’t affect my problem at all. (Also I have this setting configured like that already, the problem persists.) – kleinfreund Jul 20 '17 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.