1

I am looking for a registry entry or group policy to hide the display name of an active directory user during the login process, not resuming a session.

Process:

  1. Username and password entered
  2. here
  3. On desktop

I have been successful so far in removing the display name from the lock screen by using group policy. The accounts are not linked to Microsoft accounts and therefore are not affected by the setting in Settings > Accounts > Sign-in options under the privacy section.

Alternatives such as changing the display name for users will not work for the purpose due to integration with other services.

  • What do you mean by "here" and "On desktop"? – testeaxeax Jul 20 '17 at 15:27
  • Thats the login process. Start by logging in with your details. Before reaching the desktop, the spinning wheel goes around with your display name nicely printed on the middle of the screen. Then you get to the desktop. – Adsy2010 Jul 21 '17 at 7:43
2

In the Group Policy Editor (gpedit.msc) navigate to "Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options" and change the value of "Interactive logon: Don't display username at sign-in" to enabled.This option is available since Windows 10 build 1703.
For more information: https://docs.microsoft.com/en-us/windows/device-security/security-policy-settings/interactive-logon-dont-display-username-at-sign-in

  • hmm, 1703 .... maybe i need to check this and update my gpos – Adsy2010 Jul 22 '17 at 19:26
  • note that the option only takes effect if the "Interactive logon: Don't display last signed-in" option is enabled too. – testeaxeax Jul 22 '17 at 19:40
  • Thanks, that one is definitely enabled. The new GPO has now been installed on the server but not able to see new lines on the client. Arguing with the policydefinitions folder. I'll probably do it at work on Monday – Adsy2010 Jul 22 '17 at 19:42
  • It works but its not appeared on the gpo list on the server. I have applied it to 1 machine via local security policy and I can confirm THIS is what I was after. – Adsy2010 Jul 24 '17 at 19:19
  • Just so you know, after updating to 1703, I can now see it in the GPO list – Adsy2010 Aug 3 '17 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.