19

I'm running Windows 10 with two monitors. Sometimes, I need to get to a file on the desktop, so I use win+d to minimize all the windows. I've noticed that when I maximize the windows again (either by pressing win+d again or manually selecting the window), some of the windows that I had on my secondary monitor have moved back to my primary monitor.

This also happens if I use different shortcuts (such as win+m) as well as if I manually minimize the window using the button in the top right.

However, this does not occur for all windows. For example, I have two Chrome windows open; one moves and one doesn't. And it seems the windows only move from the secondary monitor to the primary monitor, not the other way around.

Why is this happening? Is there any way to fix it so that the windows stay where they were before being minimized?

3
  • 6
    I am experiencing the same issue. Try this as a workaround and let me know if it works for you: if you have a window for which this is occurring, move the window to the desired monitor, then click the "Restore Down" button in the upper-right corner of the window to make it go from full-screen to windowed, then click the button again to reset it back to full screen. From that point on, when you minimize the window, does it stay on the right monitor? My theory: the bug in Windows is that the window always returns to the monitor where the window started in windowed mode vs full-screen. So, for ex
    – GuyPaddock
    Aug 16, 2017 at 14:50
  • 1
    @GuyPaddock You should add your comment as an answer as it works perfectly and saved me a lot of time searching around. Thank you! Jan 22, 2018 at 10:08
  • Deleting the default.rdp file in your documents folder (its hidden) worked for me
    – Jez
    Oct 15, 2021 at 6:06

4 Answers 4

30

Try this as a workaround and let me know if it works for you: if you have a window for which this is occurring, move the window to the desired monitor, then click the "Restore Down" button in the upper-right corner of the window to make it go from full-screen to windowed, then click the button again to reset it back to full screen. From that point on, when you minimize the window, does it stay on the right monitor? My theory: the bug in Windows is that the window always returns to the monitor where the window started in windowed mode vs full-screen.

1
  • 1
    Suprisingly worked :) thank you.
    – spetsnaz
    Jul 21 at 19:17
0

I just ran into this issue with someone here at my company. Go into taskbar settings under "Multiple Displays" you will find an option to change "show taskbar buttons on" and change the option to "taskbar where window is open" and that fixed our issue. Maybe it will help for you.

1
  • The behavior of "show taskbar buttons on" "taskbar where window is open" will show the windows on the taskbar of the associated screen. The poster (and myself) already had this enabled. What is happening is on minimize the window on the taskbar would jump from the screen it was opened on to another screen. Without the setting you mentioned, you would see every window on every taskbar regardless.
    – Ari
    Jun 29 at 0:34
0

I had a similar, but worse, problem and worked out a solution thanks to Guy's answer. When I clicked Restore Down the window disappeared and I could only maximize it to main window. (Selecting anything else like Move from the Shift+Right-Click context menu did nothing.)

Eventually, I just closed the Window then in another Chrome Window I restored the windows using the the top-right (Chrome) button then History => Restore 27 tabs. This brought up all the same pages in a new Chrome window that did not misbehave.

Of course, this solution only works for Chrome but I think the problem only affects Chrome under Windows 10 as that is where everyone reports having a problem.

0

Posting answer as I don't have enough points to comment on GuyPaddock's answer.

My problem was with an RDP session that maximized to primary display after being minimized, even if the configuration file says to open in full-screen on monitor #2 (which works on initial connection).

I solved this by exiting full screen, closing/crossing out the session (while still windowed) and then reconnecting.

EDIT: Apparently this wasn't a permanent solution, in my case any way.

Not the answer you're looking for? Browse other questions tagged or ask your own question.