After Creators update, MS Edge changed its language (menu, settings, etc.) to english. Is there any way to switch it back to my native language? Everything else is OK, language and location settings in the system did not change. Not that it bothers me that much, but I would like to have consistent language across the system like it was before the update.

  1. Press the WINDOWS key
  2. Enter "Control Panel"
  3. Click on "Control Panel"
  4. Click on "Clock, Language, and Region"
  5. Click on "Language"
  6. If you can see your preferred language move it to the top and log out, if it's already on the top move it down, log out, log in and move it up again and then log out.
  7. Now Edge should use the right language.

This appears to be broken in Edge – I cannot determine where Edge is getting its languge settings from, but it's not the Settings or the Control Panel. In the image below you can see the HTTP Accept-Language header being sent conflicts with the OS settings (but does match the keyboard).

HTTP Accept-Language header not consistent with OS laguage settings

Had to edit the registry, as described here (cross post in German):

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\International]
"AcceptLanguage"="en-US,en;q=0.9,de-DE;q=0.8,de;q=0.7"

Works in Edge 42 here

New contributor
crusy is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.