1

So I have a GPT internal hard drive which I fully encrypted with VeraCrypt under Windows 10 64Bit (on a UEFI GPT drive).

Now I'd like to access it under Debian 9.0 or an outdated version of Windows 10 64Bit.

Under Windows 10 (on another UEFI GPT drive) it tells me that it's a 16TB Healthy GPT Protective Partition in the disk management. Under properties its "partition style" says MBR.
In VeraCrypt it shows as follows:
Harddisk 1: 2.7 TB
\Device\Harddisk1\Partition1 16.0 TB

I could not mount either.

Prior to this I tried accessing it under Debian without adapter and using ZuluCrypt which didn't work.

Could it be a problem with my internal hard drive adapter? I think this might be the cause; however if that's the case I'm not sure why it wouldn't work under Debian (is it supposed to?). Any ideas? What would you recommend me to do to access the data with these OS?

  • 2
    This sounds like a 512-byte versus 4k sector issue to me. I've seen some cases with older hardware where devices that report 512b logical sectors with 4k physical sectors present differently depending on what OS you use and what hardware they're connected with. Unfortunately, the only way to deal with such issues is to find an adapter that works correctly under the OS you need to access it from. – Austin Hemmelgarn Jul 21 '17 at 18:25
  • 2
    Why are you not using VeraCrypt in both cases? Based on research and similar questions about this problem makes me believe that VeraCrypt GPT support is done by non-traditional methods – Ramhound Jul 21 '17 at 22:46
  • @Ramhound Thank you once again; I tried it with VeraCrypt and it's working now! – mYnDstrEAm Jul 23 '17 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.