0

My Imac stalls when starting up with the progress bar not progressing beyond halfway.

I've searched around and tried everything I've been able to find...

I've started in safe mode - and it's weird. Very slow and old screen overlapping new screen when I scroll.

I've booted in recovery mode and reset the PRAM

I've reinstalled IOS and when it goes to re-start, the progress bar again stalls

I'm figuring I'll soon be having to purchase a new machine. Am I right?

2
  • You haven’t given us enough information to make a firm diagnosis from here. So far it just sounds like a failing hard drive. Maybe you should edit this question to ask how to get it working again rather than asking if it’s dead. Include the exact model and exactly what you’ve tried so far. Also note that Apple stocks replacement parts for 7 years or more, so even a fried MLB can be replaced. And other shops could even fix a fried MLB.
    – Spiff
    Jul 22, 2017 at 3:45
  • Since it is starting (and succeeding partially at it) it is very much not dead. As to the cause. Any diagnostic logs? Any error messages? What happens when you check the partially installed drive from another computer? Etc etc.
    – Hennes
    Jul 22, 2017 at 15:13

3 Answers 3

0

In my experience as an Apple certified technician, this problem is either related to a failing hard-drive or a bad logic board.

I would go to a Genius Bar and get it checked. I believe the diagnostics are free.

0

During your next boot up, hold command-v, that will try to boot in verbose (text) mode. A lot of stuff will scroll by but wherever it's getting held up in the boot process may become obvious doing this.

I.e., if you end up doing this and seeing lines like:

disk0s2: I/O error

That would mean the hard drive is having a physical read error and would need replacing and makes sense that you can't continue boot.

Give it a try, maybe we can find out quickly before you lug is down to the Apple Store.

0

I'm not denying the other [currently two] answers may be correct, but there's a [tedious but] simple set of tests which needs little expertise to run...

If it works in Safe Mode, first suspect would be 'something you installed' - which I know is hugely broad, but...
you can just start over & reinstall the OS from Recovery. Nothing is lost.

If no joy [because that would not uninstall anything you may have added that broke it], AND you have a solid Time Machine backup, use Internet Recovery to a reformatted drive, then restore from TM once you have tested it works when clean.

If the restore breaks it again, then you will need to start over from Internet Recovery & this time pull the Time Machine backup, a bit at a time, manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.