I'm facing this problem in the last 2 days. Following a huge number of tutorials with anything working, I'm here to get some type of tip or advice on what should I do.

Here is the basic history.

I bought a new Samsung computer with Windows 10 (FYI, is a Samsung NP300E5M-XF3BR). I installed a Dual Boot with Fedora 25.

To achieve it, I followed this tutorial and this video's instructions, since I'm a Ubuntu user and was afraid to do anything wrong when testing new Fedora for the first time in my computer.

Ok, Secure Boot disabled, UEFI OS selected in the BIOS, partition created in Windows, Fedora 25 in a bootable USB (created using YUMI)

However, by my mistake, I leaved Fedora automatically create the LVM partition instead of create it by myself as recommend in the video and here the problem starts.

I was unable to boot from HD and just boot the GRUB using a USB stick. I tried a lot of BIOS configurations but this was the only option in all of them.

Without USB stick plugged, the system did not boot and just show a message like "ALL BOOT OPTIONS ARE TRIED. PRESS F4 FOR RECOVERY...", but F4 just reboot it. With USB stick plugged,I got the GRUB, but just Fedora was working (the installed one, not liveUSB), windows was just rebooting.

I formated the LVM partition again and followed the installation guide, this time creating the partitions by my own. Now, the boot is still working just with USB, but even grub is not working. When I boot without USB, I just see a message like "Booting...1,2,3,4" and pressing 2 the system restart.

The partitions are accessible, I can mount them and check the files.

Here is a image of GParted running in a Ubuntu live instance.


After a lot of tutorials, i already tried

  • Restore the MBR using testdisk (does not change anything)
  • Use Easus Partition manager to fix UEFI (can't access the command prompt)
  • Use rEFIind to fix the bootable section just show an option to restart the computer an access to a shell with limited commands where I can`t do anything.
  • recover factory default using the Samsung recovery partition, but it`s unavailable.
  • Use the boot-repair in a Ubuntu live instance with the following result message "The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), after making sure your BIOS is set up to boot USB in EFI mode."

After all this long history (sorry for this), I'm here to get any tip or advice. What should I try next?

As I said, its a new computer, so I don't have any data to lose, I accept anything, even access the recovery samsung partition to reinstall everything.

The BootInfo summary that I got from Boot-Repair was uploaded to here

  • If you have the windows activation key you can full reformat your HDD and start from scratch. – Biswapriyo Jul 22 '17 at 20:12
  • 1
    @Biswa isn't windows 10 saving the hardware configuration to reactivate windows automatically without needing a key? – testeaxeax Jul 22 '17 at 20:20
  • @Biswa. Thanks for your tip, but I does not have the key. I think that all the original windows info is in that recovery partition, that is also inaccessible to me. – James Jul 22 '17 at 20:23
  • @James open your BIOS/UEFI options and check if the overview page (where cpu name, installed ram and such information are displayed) displays something like "License: <something>", "Key: <something>", that would indicate that your BIOS stores the license key for you, which would be the standard these days. – testeaxeax Jul 22 '17 at 20:36
  • @nullterminatedstring. Thanks for your tip, but Unless I'm missing somthing, I don't have this info. See here. Is that page that you are talking about? – James Jul 22 '17 at 21:19

Your BootInfo summary looks OK, with the caveat that it appears to have been generated from a BIOS/CSM/legacy-mode boot, and so provides no information on the EFI boot variables. Also, there's a BIOS-mode boot loader installed on /dev/sda, but that should not interfere with EFI-mode booting. It's also possible that I've missed some critical diagnostic detail. Here's how I recommend you proceed:

  1. Download a USB flash drive or CD-R image of my rEFInd boot manager.
  2. Prepare a boot medium from the rEFInd download.
  3. Reboot into rEFInd. It should provide you with options to boot either Windows or Fedora. Test both of these options.
  4. If both options work, boot into Fedora.
  5. At this point, you have several options for what to do (not necessarily mutually exclusive):
    • You can open a Terminal, type su to become root, type efibootmgr -v, and post the output here (edit your question to add the output) for more analysis. This is purely diagnostic.
    • You can keep using rEFInd on the removable medium to boot. This is likely to be awkward, but should work.
    • You can install the rEFInd RPM. It should then take over as the main boot loader and your problem should be solved. One caveat: Whatever prevented your installation from booting normally right after you installed Fedora might also affect rEFInd, in which case the efibootmgr output may be helpful.
    • You can attempt to repair the GRUB boot entry. A blind, brute-force way to do this is to re-install grub (grub-install as root); but this appears to have been done as part of the Fedora installation, so I'm skeptical that it would work any better at this time. Repairing the boot list by examining the efibootmgr output and then issuing system-specific commands based on that knowledge might work.
    • Delete the BIOS-mode boot loader from /dev/sda by typing (as root) dd if=/dev/zero of=/dev/sda bs=440 count=1. Note that this command is potentially very dangerous if you mistype something. In particular, be sure that the bs=440 and count=1 options are correct; if you write too much data, you'll damage the partition table, and potentially beyond! The point of this action is to remove a BIOS-mode boot path that might be interfering with your EFI-mode booting. Such interference should not happen, but there's no real standardization in how computers decide whether to boot in BIOS mode vs. EFI mode, so there's a chance that this BIOS-mode boot code is causing problems.

In some cases, it might be necessary to tweak your firmware settings or adjust boot loader locations and filenames. In particular, your firmware may be set to boot in BIOS/CSM/legacy mode, which would explain why it's not booting now; or the boot entries (stored in NVRAM) might be hopelessly messed up, necessitating restoring all the firmware settings to their defaults.


rEFInd's menu being devoid of OS boot entries indicates that rEFInd can't locate any boot loaders, which is at odds with the BootInfo summary information, which shows boot loaders at locations that rEFInd should be able to detect on /dev/sda1 (see near the top of the output). The most likely explanation is filesystem damage -- some EFIs are much more sensitive to this than most OSes. Such a "damaged-but-not-damaged" situation can arise because of a failure to disable the Windows Fast Startup and Hibernate features, as described here and here, respectively. If you can get Windows to boot, I suggest you disable both of those features and try again. You might also try running CHKDSK on the ESP from Windows, or dosfsck on it from a Linux emergency disk. In a worst-case scenario, backing up the ESP, creating a fresh filesystem on it, and restoring its files may work to repair subtle filesystem damage. This will require either matching the filesystem serial number ("UUID" in Linux, although it's not really a UUID) to what it is now or updating /etc/fstab to replace the old serial number with its new one. (You can find the new UUID via blkid, as in blkid /dev/sda1 as root.)

  • Thank you for this complete tutorial, sure that will help others with similar problem. In my case, I tried it, but when I boot with rEFInd, I can't boot on any system. I have a entry to a shell prompt and entry to reboot the computer. :\. Thank you anyway – James Jul 28 '17 at 12:49
  • Please see my edit, above. – Rod Smith Jul 28 '17 at 13:59
  • Ok, I'll try these new options. Thank you very much. – James Jul 28 '17 at 14:30

I would delete all non Windows partitions first.

Then boot from a Windows 10 installation USB/DVD in UEFI mode and go to command prompt.

Then I would rewrite MBR (not needed for UEFI boot but does not harm).

Then map EFI system partition(ESP) on hard disk to say S: (if not already mapped).

Then use bcdboot to fix booting:

bcdboot N:\windows /s S:

where N: is where Windows is, S: is ESP.

See "Fix Windows boot" for more info.

  • I can try it. When you say "all non Windows", it includes that reserved Samsung partitions or just my new Fedora one? – James Jul 23 '17 at 17:45
  • Reserved Samsung partitions should be kept - I suppose they are for resetting computer to factory defaults. – snayob Jul 25 '17 at 18:54
  • I tried it, following all the instructions in the link, but it doesn't work. I'm still booting just with USB stick. At least, i can use the windows recovery tools and access the command prompt now. this is something. Thank you anyway. – James Jul 28 '17 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.