I installed Gitkraken as I have a few projects I want to work on with my KDE Neon box. now I was pretty sure I installed everything but I ran gitkraken in a terminal and I got this

Node started time: 1500754704472
libgnome-keyring.so.0: cannot open shared object file: No such file or 
Error: libgnome-keyring.so.0: cannot open shared object file: No such 
file or directory

(I'll post the rest if deemed necessary)

The problem is I have keyring installed

lotus@Lotus-HackBook:~$ gnome-keyring
usage: gnome-keyring command [options]
commands: certificate-exception

I have no idea whats going on.

  • 4
    I'm voting to close this question because the problem is not reproducible. OP reported in a self-answer (deleted, apparently as a "non-answer; visible to 10K users), that the problem disappeared after sudo upgrade.
    – fixer1234
    Dec 6, 2018 at 8:38

4 Answers 4


On Ubuntu / Debian and similar:

I installed libgnome-keyring-common and libgnome-keyring-dev on ubuntu 16.04 which solved it for me:

sudo apt install libgnome-keyring-common libgnome-keyring-dev

This is the Ubuntu version, should work on Debian etc. too. So you don't have to find out the package names.

Thanks to libroman2.


On Ubuntu 18.04.01 it's this one:

sudo apt install libgnome-keyring0

Notice the '0' at the end.


I had the same error. Even though you have gnome-keyring installed, you specifically need libgnome-keyring. I would try to find a package to install that starts with libgnome-keyring. Good luck!


i got it working by manually installing two debian packages:

see also:

  • Welcome to Super User. Could you add a few sentences to the answer to explain why this solves the problem? It looks like the last link might relate to that, but links break and then this wouildn't be clear. The link can be used for attribution and further reading. Thanks.
    – fixer1234
    Dec 5, 2018 at 20:04

Not the answer you're looking for? Browse other questions tagged .