I assigned a hotkey to change my keyboard layout to Dvorak:
Start > Settings > Time & Language > Region & Language > Additional date, time and regional settings > Change input method > Advanced settings > Change language bar hot keys > To English (United States) - United States-Dvorak > Change Key Sequence

But it doesn't work. I tried all the different modifiers (Ctrl, Ctrl+Shift, and Left Alt+Shift) with every number.
Only the default layouts like English (United States) can be assigned to a hotkey.

My Google-fu didn't find me anyone with the same issue. Any ideas how to fix this?

  • 1
    Since my PC's last Windows update, I find all user-set keyboard shortcuts fail, though that may not be related to your issue. You could try a third-party keyboard shortcut manager, such as Clavier+, to launch a .bat file that switches the layout. Good luck getting Dvořák to work. Jul 23, 2017 at 21:58

1 Answer 1


I have encountered the same issue when I switched from Win7 to Win10. The following method worked for me: Under Advanced keyboard settings, I chose English (United States) - United States-Dvorak in Override for default input method

  • The OP was specifically asking for keyboard shortcuts. Perhaps I am missing something but your answer appears to refer to menus?
    – Burgi
    Dec 3, 2019 at 9:16
  • After you set your keyboard shortcuts, some of the layouts does not work (specifically dvorak). when overriding default input method makes the shortcuts work for me.
    – mikikosam
    Dec 3, 2019 at 11:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .