0

My Windows 10 Professional can see only hard drives:

Screenshot of windows only showing local disks

DiskManager and BIOS can't see flash drives too.

Maybe it is linked with turning on and off my Linux subsystem on my Windows 10. I turned it on in "Turn Windows features on or off" and used Bash for Windows in order to install VirtualBox, Vagrant and Ansible.

sudo apt-get update
sudo apt-get install virtualbox

sudo apt-get update
sudo apt-get install vagrant

sudo apt-get install software-properities-common
sudo apt-get-repository ppa:ansible/ansible
sudo apt-get update
sudo apt-get install ansible

Also I have tried to set a locale:

sudo update-locale LANG=en_US.UTF8

Then I have closed bash in order to reopen it with new locale.

But my Bash on Windows didn't open again. Now it just opens and closes immediately.

I have tried to turn it off (in "Turn Windows features on or off") and turn on again:

  1. Turn off.
  2. Reboot my computer.
  3. Turn on.
  4. Reboot my computer.
  5. Open WindowsPowerShell as administrator:

    PS C:\windows\system32> bash
    Error: 0x80070002
    PS C:\windows\system32>
    

Then I also tried to do it from cmd:

lxrun /uninstall /full
lxrun /install

And I have Error: 0x80070002 again.

And at a result I can't work with usb-drives. So I can't load from bootUSB.

  • First of all: VirtualBox cannot work in WSL. It relies on kernel modules. // It appears your Windows installation is damaged. Run sfc /scannow and see if that fixes the problem. Dism /Online /Cleanup-Image /RestoreHealth may also help solve a broken system. – Daniel B Jul 24 '17 at 10:29
  • Thanks a lot, Dism /Online /Cleanup-Image /RestoreHealth returned my USB-boot. I don't think that I will continue use Bash for Windows, so, I didn't try to turn it on again after use this command – NaSt Jul 24 '17 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.