3

My default page in MS Edge is Google. When I load Edge, I can see the google URL in the address bar, then it changes to this

ms-appx-web:///assets/errorpages/acr_error.htm#http://www.google.co.uk/

and then Edge disappears. It's clearly crashed but I don't see any warning or message.

Even if after Edge opens I hit ESC loads (to stop it loading/processing) it still crashes.

Despite how quickly I try, when I open Edge and I try to open settings or similar, no windows show - it just crashes as explained above

Application under Event View shows

Faulting application name: microsoftedgecp.exe, version: 11.0.14393.953, time stamp: 0x58ba5911
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000001b1fa2b0011
Faulting process ID: 0x2934
Faulting application start time: 0x01d3047308e8116e
Faulting application path: C:\WINDOWS\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\microsoftedgecp.exe
Faulting module path: unknown
Report ID: 63cde917-9695-4910-a45e-f0f252c7dbd4
Faulting package full name: Microsoft.MicrosoftEdge_38.14393.1066.0_neutral__8wekyb3d8bbwe
Faulting package-relative application ID: MicrosoftEdge

What do I need to do to fix this?

I did a chckdsk and it found no errors or vunrabilities ( I can't remember the exact message).

I restart the computer and it's working. After a while (< 1 hour) of moderate use (using only GitHub and Visual Studio) the same issue returns. A restart appears to fix it temporaly.

  • To address the actual question: Have you tried clearing the browser cache and cookies? – Jeff Zeitlin Jul 24 '17 at 12:04
  • How @JeffZeitlin. As I mentioned, I can't get into any settings in Edge. I've attempted this via IE though – MyDaftQuestions Jul 24 '17 at 12:04
  • 1
    I'm not on a Windows 10 computer at the moment, but on earlier versions of Windows, one could go into the Internet Options control panel and do it from there. That might also be a way to change the default (a.k.a. "home") page as well, which might let you get into the browser to check settings and cache. – Jeff Zeitlin Jul 24 '17 at 12:06
  • @JeffZeitlin I wouldn't be at all. I'd just tell you, that it won't run on my OS. That's of course different to my suggestion of trying another brwoser, which actually does run on W10. – Eugen Rieck Jul 24 '17 at 12:15
  • 2
    <sigh> not using Edge isn't an acceptable solution to the author's problem of being unable to start Edge. If that's all you have to bring to the table that's not an acceptable answer – Ramhound Jul 24 '17 at 12:35
6

This was happening to me too. Literally as I was writing this post I came across a Technet link and it's now fixed!

Error:

Faulting application name: MicrosoftEdgeCP.exe, version: 11.0.16299.15, time stamp: 0x59cda7cd
Faulting module name: edgehtml.dll, version: 11.0.16299.19, time stamp: 0x4f438703
Exception code: 0x8000ffff
Fault offset: 0x000000000064c834
Faulting process ID: 0x2f54
Faulting application start time: 0x01d346ea44a23ac8
Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdgeCP.exe
Faulting module path: C:\WINDOWS\SYSTEM32\edgehtml.dll
Report ID: 902ddd65-50c3-48c8-81d1-d6e6c3c6d447
Faulting package full name: Microsoft.MicrosoftEdge_41.16299.15.0_neutral__8wekyb3d8bbwe
Faulting package-relative application ID: ContentProcess

Solution: Run the following in an elevated Command Prompt:

reg add "HKCU\Software\Microsoft\Internet Explorer\Spartan" /v RAC_LaunchFlags /t REG_DWORD /d 1 /f

https://social.technet.microsoft.com/Forums/en-US/4af16a6b-00fb-452f-91dd-d384a4b0797a/microsoft-edge-crashes-on-windows-10-version-1703?forum=win10itprogeneral

  • This fixed it for me when I tried 5 other solutions. Thanks @toastpaint! – Steve Bauman Mar 7 '18 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.