2

Every time I shut down or reboot the computer I get the following error as it's shutting down...

explorer.exe - Application Error

The instruction at 0x00007FF66EBA8A12 referenced memory at 0x0000000000000030.
The memory could not be written.

I got a screenshot via RDC

Explorer error message showing memory addresses

The hex refs are always the same.

BitDefender & Malwarebytes come up clean. sfc /scannow is clean.

Running the following to a locally-mounted image:

dism /online /cleanup-image /RestoreHealth
dism /online /cleanup-image /RestoreHealth /source:WIM:H:\sources\install.wim:1 /LimitAccess  

Results in the following error message:

The source files could not be found.

Use the "Source" option to specify the location of the files that are required to restore the feature.

no matter what I try.
Google has failed me on getting round that so far, but it's still work-in-progress.

Edit:
Nuke & pave is currently not an option. I tried it & the result for some reason cannot be activated. Best guess is that the machine started life as WInXP, was upgraded to Win7 Home, then anytime upgraded to Win7 Ultimate, then to Win10 [during the free upgrade period].
I guess it's just not capable of keeping track over that distance.
I reverted to last backup [the one with this issue] & activation is OK again.

From comments...
MemTest86 found one bad RAM module - however, removing it did not fix the error.

Where to look next?

Windows 10 64-bit Build 14393

  • 2
    Possible bad memory module. – Moab Jul 25 '17 at 0:52
  • @Moab - Good call - in fact MemTest86 does show one bad module - unfortunately removing it does not fix the error :/ – Tetsujin Jul 25 '17 at 8:18
  • if pointing to a WIM fails, it means a file is corrupted that was installed via an update. check CBS.log to see which file is missing and add the MSU to the WIM with DISM before pointing to the WIM as source – magicandre1981 Jul 25 '17 at 15:33
1

I'm going to answer this myself, just because I technically managed to 'fix' it... I might leave it to others to figure out quite how it worked...

The 'fix' - I installed the Creator's Update - Build 15063

This in itself took a lot of juggling. I ran every troubleshooting tool known to man, whether they seemed apropos or not [Click Start, type troubleshooting, hit Enter, on the left select 'see all'... run every single one, as admin if appropriate under the advanced tab for each] many many reboots later...

I also ran Windows All-in-one Repair tool from tweaking.com a lot of times; many times it hung the machine. Many times I had to run chkdsk & try again.

Eventually, the Creator's Update, which had failed several times before, finally stuck.

This 'fixed' my DISM issue, presumably by replacing the catalog it was comparing to.

It also fixed my explorer.exe crash at shutdown.

[I deserve no interwebz points for making this work... it was two days of Google & guess & try & hope & try again]

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.