2

Each new version of Excel constantly becomes worse.

In earlier versions of Excel I was just able to open CSV file and work with it.

I was unable to this for Excel 2010: How to control CSV import into Excel 2010 and got an answer that CSV is now moved to data import.

Now I am at Excel 2016 and data import also stopped working. Instead of importing data, it creates some smart object, which behaves differently, than normal worksheet. See picture below:

enter image description here

The question is the same: how to import CSV into Excel?

Only import, without any further things.

1

Steps to import CSV:

1) Open Excel file into which you want to import the CSV (Or just open Excel to a blank workbook)

2) In the ribbon, go to Data tab and click on "From Text/CSV"

3) Select the CSV file that you want to import.

4) In the dialog where you are shown a preview of how the data looks, where the header has the name of the CSV file, click on Edit at the bottom (which is in between Load and Cancel)

5) Excel will now open a "Query Editor" as though the CSV file was a database to connect to. Here, you can change the data formats if you want to by selecting the column(s) and "Data Type" button in the "Transform" section of the "Home" tab in the Query Editor's ribbon. (Pro Tip: Select any cell and press Ctrl+a to select all the data ;) )

6) If you change the data type(s) Excel 2016 will ask you if you want to "Replace current" or "Add new step". I clicked on Replace current, but I guess for some scenarios, you would need to click on Add new step.

7) Now, click on the "Close & Load" button (should be the first one) on the Home tab.

8) You will see the data inserted into a new sheet, but it's still "connected" to it's data source (the CSV file) so click on "Unlink" in the Design tab's External Table Data section and click on OK to remove the query definition from the sheet.

9) Finally, you will need to delete the "Query" which would be open in a sidebar when you closed and loaded the CSV data into Excel. To do that, right click on the query entry, select "Delete" and confirm the delete action.

You can now close the Queries and Connections sidebar and enjoy working on your imported data!

  • As a final step: Select the table, then on the design tab click 'convert to (normal) range' to turn it into a regular part of the spreadsheet instead of a nested table. – Ash Apr 3 '18 at 19:22
1

I had the same problem. You can actually turn back on the old (legacy) import wizard.

  1. Go to File > Options > Data.

  2. Enable on any or all of the options that you want to use under "Show legacy data import wizards"

  3. Click on "OK"

  4. Now back in excel go to the "Data" tab

  5. Click on the drop down arrow under "Get Data"

  6. Select the option you want to use under "Legacy Wizards"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.