4

I have read Windows SSTP VPN - connect from Mac but the instructions are too terse for me.

I want to connect to a VPN using SSTP and a certificate. I've installed the certificate in Keychain using the instructions for How to Import and Export SSL Certificates in Mac 10.7, although I'm using Mac OS X 10.11.6 the instructions seem fine.

I've installed sstp-client but I can't get it to run (see Edit below). I used the commend line:

sudo /usr/local/sbin/sstpc/sstpc --log-stderr --cert-warn --user <user> --password <password> <server> usepeerdns require-mschap-v2 noauth noipdefault defaultroute refuse-eap noccp

inserting appropriate values for <user>, <password> and <server>. The username is domain\userID which I enclosed in double quotes due to the backslash, and the server included the port number (like foo.bar.net:443) so I put that in double quotes too.

I'm asked for a password, then get an error message:

sudo: /usr/local/sbin/sstpc/sstpc: command not found

Running:

ls -ls /usr/local/sbin/sstpc

returns:

8 lrwxr-xr-x  1 userfoo  admin  41 24 Jul 14:42 /usr/local/sbin/sstpc -> ../Cellar/sstp-client/1.0.11_1/sbin/sstpc

where "userfoo" is my username.

Trying in iSstp, I've filled in all the details as for the commend line, the command options are the default:

usepeerdns require-mschap-v2 refuse-eap noauth noipdefault defaultroute

then selecting Connect runs for a few seconds then returns "Not Connected!".

I've also tried looking through https://www.axot.org/2015/03/03/isstp-a-sstp-client-for-mac-osx/ but no success there either.

Can anyone help me out with a suitable command line or iSstp setup?

Edit

One issue was that there was one too many "sstp" in the command, it should have been:

sudo: /usr/local/sbin/sstpc ...

While that get's the command to run, I'm then asked for my password and the terminal never returns. Similarly in iSSTP, which attempts to connect for a few seconds, then times out.

Reading the manual for SSTPC, I turned on logging and got to:

Sep 21 16:41:09 sstpc[20411]: The certificate did not match the host: foo.bar.net:443
Sep 21 16:41:09 sstpc[20411]: Verification of server certificate failed
**Error: Verification of server certificate failed, (-2)

So seems to be a certificate issue. What is "(-2)"?

4
  • My need was the same but finally I've found the comment that sstpc client does not support EAP / Certificate based authentication: sourceforge.net/p/sstp-client/discussion/1499218/thread/… Commented Mar 15, 2018 at 15:39
  • did you managed to connect anyway? or did you found different client? Commented Mar 15, 2018 at 15:41
  • 1
    @AndrzejMartyna—I gave up trying with Mac OS and used a Windows PC.
    – RobG
    Commented Mar 15, 2018 at 20:27
  • thanks, finally I also did the same. Hope some solution will show up in the future. Commented Mar 16, 2018 at 6:46

1 Answer 1

2

Please try to change the username in iSstp to Domain\\Username, use two backslash.

If it is still not connected, try to run the command line using sstpc from homebrew you installed, i.e. use "/usr/local/sbin/sstpc" instead of "/usr/local/sbin/sstpc/sstpc" in you original command line.

If command line works (it should work), then you can replace the sstpc file in iSstp package with the sstpc from homebrew, change the destination directory to where your iSstp.app located.

sudo cp /usr/local/Cellar/sstp-client/1.0.11_1/sbin/sstpc /Applications/iSstp.app/Contents/Resources 

Now you can try iSstp again, it will work too.

If iSstp still doesn't work, please report here https://github.com/axot/isstp/issues

1
  • Thanks for your help. The command line had one too many sspts in it (can't understand how I missed that). While that got sstp to run, it didn't get me connected. Reporting…
    – RobG
    Commented Sep 21, 2017 at 6:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .