Windows 10 brought new PATH environment variable editor, but for some reason, it just stopped working for me.

The odd thing is that path editor is "broken" only for system variables.. in case of User variables, the editor is fine.

System editor:

enter image description here

User Path editor:

enter image description here

As you can see, both are editing Path variable, however both use different editor. This is quite infuriating, have you ever encountered such error?

  • It's not an error. The system and user PATH variables are different things. – DavidPostill Jul 26 '17 at 17:54
  • They are, however the editor is not, that should be the same because I was editing system Path with the same editor a week ago. – Lone Wanderer Jul 26 '17 at 17:56
  • Ah. OK. Reopened. – DavidPostill Jul 26 '17 at 17:57
  • 1
    The new editor is much cleaner and organized, easier to navigate and to make changes. For example load priorities, that is why this bug is quite painful.. while this style of editor (which is inherited from windows 7) is working, it's not, great.. – Lone Wanderer Jul 26 '17 at 18:08
  • 1
    @LoneWanderer The issue is that the first entry on your Path variable starts with a non-built-in environment variable. Move %SystemRoot%\System32 (the third entry) to the front of your path, and this issue will be resolved. Note that in your first screenshot, the background dialog displays the path as %M2_HOME%..., whereas the second displays the path as C:\Users\.... That indicates that USERPROFILE is a built-in Windows environment variable, but M2_HOME is not (This can be verified by observing USERPROFILE isn't listed in HKCU\Environment). See my answer for more details. – Jeff G Dec 12 '17 at 1:08

I was having the exact same issue, and finally figured this out via trial-and-error. The issue is that there is a bug in the Windows 10 Path environment variable parser. In my case, the first entry in my Path environment variable started with an application-defined REG_SZ environment variable (e.g., Path was set to %MyAppPath%\some\subdir;...). From my testing, it appears that the first entry on the Path must not start with a non-built-in environment variable.

For example, if my Path environment variable were set to %SystemRoot%;%MyAppPath%\some\subdir;..., it would be editable in the Path list view editor, since SystemRoot is a built-in environment variable. If you swap the first two paths in that example, I observed the symptom you describe (that editing the Path variable results in opening the standard text editing dialog instead of the Path list editor).

To fix this issue, ensure the first entry in your Path doesn't start with a non-built-in environment variable.

  • 1
    Note that this issue has been resolved by Microsoft. – Jeff G Jul 13 '18 at 15:49
  • Jeff G, I still have that problem. How can I get that fix from Microsoft? – Holger Jan 22 '19 at 15:25
  • Unfortunately, I'm not exactly certain when this fix was rolled out. What I do know is that this symptom is no longer occurring on any of my machines, which are Windows 10 Enterprise 1709 build 16299.904, and Windows 10 Professional 1703 build 15063.1029. Is your system up-to-date? What is your Windows version/OS build #? – Jeff G Jan 22 '19 at 20:33
  • I currently use Windows 10 Professional 1809 build 11763.253. Your trick with not starting the Path with a non-built-in environment variable worked, but was actually required. – Holger Jan 23 '19 at 15:24
  • I'm use Windows 10 Professional 1903 build 18362.239 and the bug still exists. What i did instead for the fix was to add a place holder as the first entry called C:\myPlaceholder and it worked fine. It doesn't seem to make a difference that the folder does not exist on the drive. – PadraigD Aug 2 '19 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.