I've had this problem for quite some time now, and so far I've found no solution - but it's really beginning to get on my nerves.

Basically, when I search for a program via the Windows start menu (the search bar), I will get the correct results - but some programs I simply cannot open.

Example: I click on the start menu and begin typing "control panel". It will show me the control panel as a search result, but when I hit enter, or click on it - nothing happens. It simply stays there as if nothing happened.

This is the same with ALL apps except the "metro" applications from the Windows Store (whatever they call them now).

The problem began after I changed the system language from English to German, and even if I switch back to English, the problem won't go away again. Here's what I have tried so far:

  • Running sfc /scannow in an elevated Powershell multiple times.
  • Reindexing the search via control panel multiple times.
  • I've run lpksetup /u in an elevated cmd multiple times.
  • I've killed Cortana and Windows Explorer.
  • I've obviously run the "troubleshooter"
  • I've made a new account for myself. It worked until I changed the language back to German.
  • Running Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} in the powershell
  • Starting Windows in Safe Mode

If I right click on the item in the search results and try to launch it that way, it says the item is not found and asks me if I want to remove it from the list.

Any help would be appeciated :)

Thanks in advance

  • That's a weird one. Have you tried any other languages besides German? Curious if the issue is German-specific or just when it's a non-English language.
    – freginold
    Jul 26, 2017 at 20:03
  • @freginold Yeah I agree it's a very weird one. I have not, however it seems to be a language change that "breaks it". Once I "break" it by changing the language to German, it doesn't matter if I change the language back or whatever - it's 'irreversable' at that point (well, at least that's what I'm trying to find out if it is)
    – Mathias
    Jul 26, 2017 at 20:46
  • You could always try a repair installation via Microsoft's Media Creation Toolkit.
    – QMord
    Jul 26, 2017 at 22:08
  • @QMord Sounds like you can answer the question.
    – Ramhound
    Jul 26, 2017 at 23:19
  • 1
    I had this exact same problem and, like you, none of the solutions you listed worked. The issue was resolved when I updated Windows 10 to version 1709 (Fall Creators Update).
    – Richard
    Jan 30, 2018 at 18:08

3 Answers 3


Okay, I've finally found a solution. To everyone who might need this in the future: the solution to this is to go to your privacy settings and enable background applications. You can turn all of the apps seperately, only the main switch has to be turned on.

Found here: https://answers.microsoft.com/en-us/windows/forum/windows_10-win_cortana/windows-10-creators-update-search-not-finding-apps/eaf70556-2344-474d-b633-e00140b0466d

  • This is no solution for me. Background Apps was always on, but I still have the same issue as you did: Searching programs yields the result, but clicking them (left or right click) won't do anything.
    – A. Vieira
    Nov 8, 2017 at 11:45
  • 1
    Thank you! After trying a myriad of solutions, this finally fixed it for me. And for the record, this is still an issue on Windows 10 v1909, i.e. more than 2 years after the Creators Update.
    – MicE
    Aug 4, 2020 at 16:04
  • Thanks so much! And for the record, yes, still an issue in '22 on v21H2
    – Tobl
    Aug 4, 2022 at 9:31

This worked for me on my Acer TravelMate:

Go to C:\Users\User\AppData\Local\Packages\

Delete the folder \Microsoft.Windows.Cortana_cw5n1h2txyewy

If you cannot delete the folder, enter into the folder and delete as many as the sub folders as your system permits.

Logout from your account and login again.

  • I was able to locate the exact folder but was barred from deleting certain files and folder in it due to them being open in various background applications. It produced some instability when interacting with the Start menu immediately afterwards but logging out and logging in, solved the stability issue and the core issue. A reboot later and it still works. Thanks!
    – brokkr
    Feb 2, 2018 at 11:06
  • I tried renaming as much subfolder as I can, and it worked too. Can you explain your answer further?
    – Gellie Ann
    Feb 8, 2018 at 1:39

I had same problem. I set AppData folder visible (unhide) and now it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .