1

Photoshop has decided it wants to be different. Instead of being slow to open files like any normal program, it's decided to be slow to close them. Not even while saving. It takes about 5 seconds to close any changed or unchanged file, regardless of whether it's on the fileserver or on my local HDD, during which time Photoshop is completely locked up. Already-saved files should close instantly, unsaved files should take only as long as it takes to save the file to close.

I'm using Photoshop CC 2015 on Windows 10 Creator's. I'm running on an older laptop but I see no increased resource usage in task manager while waiting for the file to close.

I have tried (in vain):

  • Holding Ctrl+Shift+Alt on startup of PS to remove settings
  • Setting my virtual memory in Windows to 16gb
  • Setting PS's memory usage slider at many different positions
  • Clearing the recent file list

What could be causing this?

  • Sounds like a problem with the virtual memory. You may want to consider increasing its value. If its set to auto manage, look at the maximum usage and set that as a minimum, just as test case. – LPChip Jul 27 '17 at 7:04
  • @LPChip What makes you think that? Oh wait, that does make sense. You're thinking Photoshop is allocating memory and Windows is giving it virtual memory, and then it's having to deallocate large chunks off the HDD? I will investigate that theory tomorrow. Thanks :) – Clonkex Jul 27 '17 at 11:48
  • @LPChip I manually increased my virtual memory to 16gb (which is huge) and restarted and I still see the issue. It's driving me nuts. It only started a 2-3 months ago as well; it hasn't always done it. Unfortunately I have 0 idea if I changed anything around that time :/ – Clonkex Jul 27 '17 at 23:05
  • Indeed. Too bad it didn't work. You could consider reinstalling photoshop, starting photoshop as administrator, then closing it (in case it somehow can't write settings and therefor does something else to cope with it, change the location of the scratch disk to a different drive, make sure you have enough disk space on the scratch disk and the primary disk. – LPChip Jul 28 '17 at 7:38
1

I had the same problem after updating my nVidia graphics driver. In the nVidia settings panel I changed the 3D settings for Photoshop.exe to "Powerful nVidia Processor" instead of the "normal" setting. The problem was solved after that.

  • Interesting. Unfortunately I got a new work PC and the problem no longer happens. Also, the laptop I had only had Intel graphics, no Nvidia. Could still have been related though. – Clonkex Feb 2 '18 at 13:33
1

I experienced this same issue in Photoshop CC 2018, Windows 10 Pro on a PC with integrated graphics (Intel Core i7 3770 - Intel HD Graphics 4000). I found that if I unchecked the 'Use Graphics Processor' option in Preferences/Performance the issue stopped.

  • I wish I still had the old laptop so I could test that. Thanks for posting! – Clonkex Dec 12 '18 at 2:57
0

Edit >> Preferences >>Performances

Uncheck the "Use graphics processor". It will solve the issue. At-least it solved for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.