1

I just want to download all the files in this link: http://www.vision.caltech.edu/pmoreels/Datasets/TurntableObjects/ImageSet070504/

I tried wget with many different options, all of them return "ERROR 404: Not Found".

For example, I tried this command, which doesn't work:

wget -nH --cut-dirs=3 --mirror --no-parent http://www.vision.caltech.edu/pmoreels/Datasets/TurntableObjects/ImageSet070504/

My wget version is 1.17.1

Suggestions?

  • The website is probably detecting you're using a robot/scraper and returning a 404. You could try sending a browser UA, or maybe Selenium or similar? – pbhj Jul 27 '17 at 11:49
0

I'm not sure what you meant about "lots of different options" but if you meant you tried different paramaters on wget instead of different servers, then 404 will mean the server is down. To test this, try pasting the link into a web browser. If it also throws a 404, then you know the server is down. If not, then just download it via your browser. Heck, I wouldn't know why it worked!

  • the link which I posted above, always works in a browser, but not work through wget. – guamian Jul 27 '17 at 15:15
  • Well then I have no clue. Have you tried something else in wget to test if the problem lies within wget? – FirePenguin Jul 27 '17 at 15:50

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.