0

I'm working on a Mac, which also hosts a Windows 10 VM. When in the office all works fine: my logged-in Windows user can access Windows shares across the local domain network, Outlook authentication works without issues, etc.

Taking my Mac home and connecting via VPN to the domain, I run into the problem that I get a login prompt when accessing a network drive. Message says (partly translated by me but the red text should be exact):

Enter network credentials
Enter your network credentials to connect to this network: {SERVER NAME}
{in red:} The system cannot contact a domain controller to service the 
authentication request. Please try again later.

I googled and found a couple of posts where people assumed DNS issues: ping/nslookup our DC from the hosted Windows works fine in both scenarios.

There's a co-worker who's having the same setup and problems with it. And, things started just a couple of days, maybe weeks, ago. Unfortunately, I have no idea where to start investigating this issue. Any suggestions how to solve this or to get started?

Thanks in advance.

Edit: Additional info: that problem only appears when the host Mac connects via VPN. If the VPN connection is created by the Windows VM, or if it's a Windows PC itself, all works fine.

Edit2: When entering my Windows credentials into the network credential prompt I can access the network shares. Seems like there's only some small parts of the automated authentication process not working. Windows authentication doesn't work for SQL Server either.

Edit3: It seems like it's kind of a DNS issue: I used to use DHCP provided DNS settings in the Win10 VM, but then I entered the Windows domain server as DNS, and now it works again. While playing with these settings I also noticed that my "Active network" (under "view your active networks" in the "Network and Sharing Center") changes from "Network X - Private/public network" to "domainname.local - domain network" when I enter the DC as DNS.

While this is a workaround that I supposedly can live with, if anyone knowns a better solution - I'm still keep to learn it.

0

It sounds like your VM isn't set to NAT, despite the fact that your ping/nslookup results would seem to contradict that. (Unless of course your DC was for some reason publicly resolvable.)

If you want the VM's traffic to traverse the VPN tunnel created on the host Mac machine, the VM will have to be set to NAT through the host's address (should be a fairly obvious option in whatever VMWare you're using, under the network section).

It's quite possible that the DC is pingable, but firewall policy is preventing other types of connections.

  • Thanks for your suggestion. I use VMware and the network settings don't leave much room for custom NATing. I use the "Shared with my Mac" option and description says it does all the NATing. For the NATing itself: I unfortunately missed out telling that when filling the network credentials dialog correctly I can access the network shares. (Will update question text.) – robbash Jul 28 '17 at 7:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.