16

Every once in a while, my Mac will do this thing where Command+F will no longer work to find/search in any application I use (Atom, Slack, Chrome, etc). Command+G still works in Chrome for "Find Next" as does Command+Shift+F in Atom. The problem seems to be solely limited to Command+F. It doesn't matter which Command key I use (left/right/built-in/external). When I pull up the Keyboard Viewer, the Command keypress registers correctly but not the F

Things I have tried:

  • Closing all applications
  • Fully restarting. The problem persists across full restarts.
  • Resetting all keyboard settings to default
  • Uninstalling Karabiner (which I use for a couple of shortcuts unrelated to Command+F)

The problem persists after trying all of the above and usually goes away after a couple of days for seemingly no reason. Has anyone run into this before or can anyone help me diagnose the issue further? This is driving me nuts.

OS Details: Macbook Pro running OS X El Capitan v 10.11.6

9
  • I have since upgraded to High Sierra 10.13.1 and it started happening again this morning.
    – Josh Cox
    Nov 14, 2017 at 15:48
  • Sanity check, first. When this problem is happening, can you verify that your keys are still being registered as pressed? Eliminating the hardware as a concern. Nov 14, 2017 at 16:22
  • 1
    The Command registers as being pressed but not the F. When I press Command + Shift + F the F is registered. So something low-level seems to be stopping that from being picked up in the Command+F case.
    – Josh Cox
    Nov 14, 2017 at 17:13
  • does this happen with both Command keys? Does it happen with an external keyboard's Command keys? Nov 14, 2017 at 17:18
  • Yes it happens with both command keys as well as external keyboard's command keys.
    – Josh Cox
    Nov 14, 2017 at 17:19

2 Answers 2

10

This has been driving me nuts for months too, and today I figured out that when I press Command+F (in that order), the F key press doesn't register. However, if I flip the order by pressing F + Command, it works again. That seems to "reset" something so that I'm able to continue using Command+F for the rest of that session. I hope this helps!

1
  • 1
    This started happening to me again this morning. F+Command does seem to work to search! Unfortunately, it doesn't seem to have the same "reset" behavior for me. I am only able to get it to work with F+Command.
    – Josh Cox
    Jun 26, 2018 at 15:31
3

this is old post but it is first in the google search results by "cmd F doesn't work", so let me post a link to working solution

https://discussions.apple.com/thread/5471806

TL;DR

  1. remove ~/Library/Caches/com.apple.Safari/Cache.db
  2. restart in safe mode
  3. restart again in normal mode
  4. PROFIT

and i'm not sure about deleting file, please someone check it

1
  • deleting the cache file is not needed for me. It seems starting the safe mode is the only solution for me.
    – Hadi Tok
    Oct 1, 2019 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.