0

In the past week or 2, I've gotten 3 BSODs. This is unusual for my lapotp that's gotten maybe 2 others in it's whole life (around 4 years). All 3 of these errors occurred while I was using the computer doing normal things such as browsing chrome.

1st bsod: kernel security check error
2nd bsod (~5 days later): kernel security check error
3rd bsod (~10 days later): unexpected store exception

This is an HP Dv7t-7000 laptop running windows 10 build 1607.

Things that changed in the system before BSODs started occurring:

  1. A week or so prior to the first bsod, I upgraded my ram from the stock 8 GB, to 16 GB purchased from here. 1 pass of Memtest86 (6 hrs long) comes up clean.
  2. A few days prior to the first bsod I hooked up this new usb 3 hub. It has been functioning as expected, and one of the kernel security check errors happened while not connected to it.
  3. A week or so prior to the first bsod I took apart the whole laptop to replace the screen which had been broken. After putting it back together it unexpectedly shut off twice within 30 mins of each other and wouldn't come back on until I reseated the ram (old 8-gig sticks at the time). After that there were no more unexpected shut offs and I assumed I had put the ram in poorly or something

Events from the System category of Event Viewer surrounding the last bsod (unexpected store exception):

  1. Error ~2 minutes before bsod: "The Delivery Optimization service hung on starting"
  2. Two Informations right before bsod:
    --The access history in hive \??\C:\Users\blain\AppData\Local\Packages\SpotifyAB.SpotifyMusic_zpdnekdrzrea0\SystemAppData\Helium\User.dat was cleared updating 26 keys and creating 2 modified pages.
    --The access history in hive \??\C:\Users\blain\AppData\Local\Packages\SpotifyAB.SpotifyMusic_zpdnekdrzrea0\SystemAppData\Helium\UserClasses.dat was cleared updating 14 keys and creating 1 modified pages.
  3. Two identical Errors on startup after bsod:
    --The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {C2F03A33-21F5-47FA-B4BB-156362A2F239} and APPID {316CDED5-E4AE-4B15-9113-7055D84DCC97} to the user BLAINE-WIN-10\blain SID (S-1-5-21-347453058-3377039792-1896365341-1001) from address LocalHost (Using LRPC) running in the application container Microsoft.Windows.Cortana_1.7.0.14393_neutral_neutral_cw5n1h2txyewy SID (S-1-15-2-1861897761-1695161497-2927542615-642690995-327840285-2659745135-2630312742). This security permission can be modified using the Component Services administrative tool.

UPDATE: 2 days later, another kernel security check error has occored when waking it from sleep mode. Here's the dump file. Worth noting that I tried reseating the ram before rebooting it and it wouldn't post. I reseated it again, and it started working fine.

UPDATE: 9 days after the last BSOD, and still going fine. Maybe reseating the ram fixed it

3
  • You could post the minidump files in a public file sharing site. – Jamie Hanrahan Jul 31 '17 at 1:12
  • what minidump files are these? – Blaine Jul 31 '17 at 12:21
  • @RickBrant ah, got it. Checked event viewer on this last one and found the appropriate one. See the bottom of my edited question – Blaine Jul 31 '17 at 13:07
0

I assumed I had put the ram in poorly or something.

No offense, but everything you said in your post screams problems that you created. Either faulty new RAM, or something not hooked back up properly. Maybe a heatsink not seated properly.

You can't assume you put the ram in poorly or SOMETHING. Ugh. :)

It will take a methodical approach to seeing what is going on. I would target the RAM first, as it is most likely the issue.

First, let me say, usually a memory test will find bad RAM. However, sometimes it flat out won't, even if you run it for a week. A lot of times it takes several passes before finding it, so it needs to run for 24 hours or more.

However, the first thing to try is run the memory test and gently tap with a plastic end of a screwdriver, or gently push on the RAM modules while the test is running. There's a good chance you still have a bad connection. The memory test will usually go haywire pretty quick if that is the problem. If it is, remove the RAM chips, buy and use some contact cleaner on the RAM and the slots and reseat everything a few times while the contact cleaner is still wet being sure to slide the chips in and out of the slot slightly depressed so there is a little resistance. This will help remove any oxidation.

You should also make sure you purchased standard RAM and not a performance memory that has odd voltage or timing requirements. It's just not worth the trouble.

6
  • haha, if I knew what was causing it, I wouldn't be asking the question :). And yeah, I assume I created the problem which is why I gave all the backstory. Didn't touch the heatsink so that's fine. And yeah I checked and the ram is pretty standard. I'll try the tap on the ram check soon and report back. Also worth noting that 2/3 times the computer was perfectly stationary when the error occurred. – Blaine Jul 29 '17 at 4:53
  • ok, had another bsod :( (see updated question), but aside from that, I tried tapping/pushing on the ram while running memtest, and nothing happened – Blaine Jul 31 '17 at 13:08
  • 1
    Did you get a chance to let a memory test complete for a full 24 hour period? The next step I would take is to run the system individually on one RAM module or the other until I was sure if it was blue screening still or not. I would first try Module #1 in RAM slot #1, then Module #2 in RAM slot #2. If you find one combination causes blue screens, then use the same slot, but swap with the other RAM module and test. Then you know if it is the slot or the RAM module. Your comments above really indicate a problem around RAM in my opinion. – Appleoddity Jul 31 '17 at 13:37
  • yeah, i'm beginning to reach the same conclusion (which is sad since it's brand new ram and I can't return it now since i'm in another country). Since this is my main work computer, it'll be difficult to find a 24 hr time period in which I don't need it, but i'll try one of these days. I'll run each module on it's own for a week or so too. It might be a while before I can report back with those results, but I'll do so once the experiment's done. Thanks for all your help! – Blaine Jul 31 '17 at 13:52
  • Well, the good news is, it only has to blue screen once to be sure the problem is not resolved. :) – Appleoddity Jul 31 '17 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.