0

My laptop is an HP Pavilion ab090na, OS is Windows 8.1 64-bit. I have disabled the password request that used to appear at the start by unchecking the relevant box after calling netplwiz(as suggested here).

However, after a few days without shutting down or restarting, I finally shut the laptop down. The next day, upon turning it on, the password request reappeared.

Why did this happen, and how can I prevent this from happening again?

To further clarify: after I've disabled the password the very first time, the box I access by calling netplwiz has never been re-checked. No particular maintenance has been carried on the laptop - just regular use. Also, after I've disabled the password the very first time, the password request window never showed up until the other day.

1

When you shut down Windows 8.1, it might just put the system into hibernate/sleep state. Try to stop your PC from asking password after awake:

  1. First open the Control Panel (Windows key + X > Control Panel)

  2. Go to Power Options > Click on the "Require password on wakeup" link.

  3. Click on "Change Setting that are currently unavailable".

  4. In the section named "Password protection on wakeup", select "Don't require a password".

Source: http://www.c-sharpcorner.com/UploadFile/7e39ca/remove-sleep-mode-password-in-windows-8/

1

Try doing it through registry editor by following this guide by Microsoft, it should behave in the same fashion as doing it through the GUI, as a resort. Be sure you type the password correctly when you put it in.

Important it may fail to autologin under three major conditions:

  1. If you mistyped your password twice the same way (if under GUI) or mistyped the login username in the GUI popbox that requested for your login or in registry editor, the login would fail. It must match exactly. To figure out your username, under netplwiz, go to your account and select Properties, then your username should appear in the box. This is what you should use for both the GUI and through registry editor. Your password you should know.

  2. This seems the most plausible explanation. If it was working at some point (from what I can understand from your post) these settings took effect. If they were never working, it won't ever work because of these settings. This note is from the link I gave you:

    When Exchange Active Sync (EAS) password restrictions are active, the autologon feature does not work. This behavior is by design. This behavior is caused by a change in Windows 8.1 and does not affect Windows 8 or earlier versions. To work around this behavior in Windows 8.1 and later versions, remove the EAS policies in Control Panel.

  3. It is because you feel like it worked and the settings changed, this may be the reason, but I'm not sure and I doubt your laptop is configured as a workstation. This note is from the link I gave you:

    An interactive console logon that has a different user on the server changes the DefaultUserName registry entry as the last logged-on user indicator. AutoAdminLogon relies on the DefaultUserName entry to match the user and password. Therefore, AutoAdminLogon may fail. You can configure a shutdown script to set the correct DefaultUserName entry for AutoAdminLogonAs. For more information, click the following article number to view the article in the Microsoft Knowledge Base: 119364 AutoAdminLogon loses DefaultUserName

Good luck! Inform me if it doesn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.