21

I got a Mac OS X virtual machine on VirtualBox and when I started it, I got into this UEFI shell:

UEFI shell

What should I do?

14

I also hit the problem of getting stuck at the UEFI shell prompt when booting from a viable disk (such as my case where MacOS had just been installed in a Virtual Machine).

I was able to fix the UEFI problems as follows (credit to VirtualBox forum):

  1. At UEFI prompt: Type exit

  2. You'll be brought into an EFI text-mode GUI.

  3. Select Boot Maintenance Manager and click.

  4. Select Boot From File and click

You should see two entries in a list (they are cryptic looking PCI bus paths).

The first is the PCI path to a boot partition that isn't working (corrupted or perhaps has no data or OS installed on it).

The 2nd partition is the recovery partition, the one you need to boot from to do the macOS installation or other maintenance/administrative tasks (including accessing Disk Utility to work on the System Volume partition without an OS running).

Click the 2nd entry, you should see (and then click):

macOS Install Data

Then click:

Locked Files

Then (if present), click

Boot Files

And finally click:

boot.efi

At that point the installer boot will continue and you should get to the point where you can attempt to repair the volume or [re]install macOS

  • 1
    This worked for me. Only slight difference was that under Locked Files there was another level called Boot Files, once navigating into that directory, boot.efi was within it. Thanks! – rastating Oct 25 '18 at 15:24
  • Thanks @rastating. I added it in italics to the steps, as a potential extra layer in some configurations. – clearlight Oct 28 '18 at 23:18
  • 3
    I have nothing in "Boot Files" also I have nothing in "Add Boot Option". Any solutions? – GrinderZ Jan 14 at 17:55
  • That's why it says then (if present). If you look at the previous comments, it was added because apparently some people do have that. If you don't, I guess you don't need to worry about it. – clearlight Jan 14 at 22:14
  • @GrinderZ follow the guide here -> forums.virtualbox.org/viewtopic.php?t=85631 , I had the USB connected with the ISO also loaded, not sure which one actually worked. – eri0o Mar 7 at 2:50
12

In VM settings General > Basic > Version set "macOS 10.13 High Sierra (64-bit)", because likely now you have setting 32-bit version.

protected by Community Jun 21 at 17:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.