0

I guess that it is not a hardware problem; And the computer recognizes all the other USBs except a specific USB.

The problem occurred after I created Fedora live USB. After the creation of live USB, this windows PC has been not recognizing the USB in [My Computer]. The recognition in diskmgmt.msc is fine. (the USB has normal partition) (I did recreate new partition by using diskmgmt.msc)

I have formatted this USB more than 5 times by using several different ways, but, as written above, diskmgmt.msc does recognize it but 'My Computer' does not.

I tried all the solutions that I found, but couldn't solve the problem.

What can I do?

  • Is the partition FAT32 or NTFS? Have you tried inserting it into another computer? – Don't Root here plz... Jul 31 '17 at 3:24
  • Do you try formatting your USB Drive with Partition Wizard Free yet? This program will help you format your USB Drive thoroughly. Because you can see all partition and unallocated space in your USB Drive and manage it. This program free for personal usage. (Download: partitionwizard.com/free-partition-manager.html) Ensure that no important files in it before formatting. Also, consider file system format (FAT32, NTFS, exFAT, etc.). Popular file systems of Windows are FAT32 and NTFS file system. – Chisanupong V. Jul 31 '17 at 3:51
  • Have you tried to give the partition a driver letter? – DavidPostill Jul 31 '17 at 10:02
0

The problem occurs because partitions on your USB drive got contaminated by foreign operating system, which causes Windows confusion. Try to clean up your flash drive (or HDD) using the standard Microsoft low-level utility DISKPART. For instructions, look here, how-clean-and-format-storage-drive-using-diskpart.

| improve this answer | |
0

You haven't said how you copied the Fedora installer to the USB drive, and this detail is critical. Some tools (like Rufus) use normal partitions on the USB drive, but other methods (like using dd in Linux) create a Frankenstein's Monster sort of partition table. The reason is that many Linux installer .iso files are designed to work either when written to a USB flash drive (which requires a GPT or MBR partition table) or to an optical disc (which requires ISO-9660 or UDF data structures). These two sets of requirements are contradictory, but can coexist if various tricks are used. The result works, in the sense that the computer can read the disk either way and install the OS; but the resulting partition table on a USB drive is very non-standard and is likely to confuse normal partitioning software.

The solution is to do a better-than-normal wipe of the disk's data structures. If you can boot to a Linux environment, the following should do the job:

sgdisk -Z /dev/sdc

You must type this command as root, or using sudo; and you must change /dev/sdc to whatever the USB drive's disk identifier is. The -Z option to sgdisk should wipe the GPT and MBR partitioning data clean. You can then use fdisk, gdisk, parted, GParted, or whatever you like to re-partition the disk in a normal way and create a fresh filesystem on the resulting partition.

A more extreme approach is to completely wipe the disk:

dd if=/dev/zero of=/dev/sdc

This command is likely to take several minutes to complete, but it will write "0" values to every byte of every sector on /dev/sdc. (Change that identifier as necessary, of course.) This will guarantee that the disk is completely empty, whereupon you can re-partition it and begin using it. If it still doesn't work at this point, then the disk's hardware is probably failing. (It does happen -- and if you just wrote a whole Linux installer to the disk, that might have been enough to push it over the failure edge.)

If you're using Windows, there are equivalents to sgdisk and dd for it. I'm less familiar with Windows tools, though, so my lazy advice is to boot a Linux emergency disk to use sgdisk and/or dd. Somebody more familiar with Windows may be able to provide a more Windows-centric solution.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.