0

I was following this guide to install FreePBX on CentOS 6.9 (minimaslist), everything worked, until the last step to install FreePBX: ./install -n from /usr/src/freepbx, I keep getting the follwing error msg:

Assuming you are Database Root
Checking if SELinux is enabled...Error!
SELinux is enabled.  Please disable SELinux before installing FreePBX.

I have disabled SELinux, by writing SELINUX=disabled in the following file /etc/sysconfig/selinux then rebooted, but I keep having the same problem. For reference, here is the output of cat /etc/sysconfig/selinux:

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted 

Here is the output to sestatus

SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
  • What does sudo sestatus show? – testeaxeax Aug 1 '17 at 19:26
  • @nullterminatedstring Just added that to the description – Ernest Dujo Aug 1 '17 at 22:01
0

I have faced this problem before: A quick search made me realise that in order to disable SELinux I have to modify /etc/selinux/config instead, doing that gave for sestatus:

SELinux status:                 disabled

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.