I am connecting a network drive to a computer using the map network drive option. If I give it the IP address (192.168.1.x) it will connect fine, but if I give it the .local address (name.local), it ends up saying that it cannot access the device. I would like to use the .local address so that in the case that the ip address gets changed (e.g. to, the computer will still know where to connect.

  • could possibly be a Master Browser issue. Do you have one always-on machine correctly set to be master browser, or do you just let them all auto-negotiate using random elections?
    – Tetsujin
    Aug 5, 2017 at 11:21

2 Answers 2


This sounds like a DNS issue. Do you have a server in place that runs DNS? If not, NetBIOS should find it by just pinging the name instead of typing ".local" after it. If you do have a server, check the DNS server settings to see if it "knows" about the device.


Sounds like you don't have DNS set up to be able to handle this. Often, if you're using DHCP to hand out addresses, the consumer-grade router will store a DNS-to-DHCP mapping. So if the router is set up to serve the ".local" DNS domain via DHCP, and I am machine1 and I get from the router, the router will store an entry saying

machine1.local = 

in its DHCP table, which is often shared by the build-in DNS server. If you're not using DHCP, the router has no idea what your hostname or DNS domain name are.

Alternatively, you could populate the hosts file on the devices (on Windows it's usually C:\Windows\System32\Drivers\etc\hosts and on UNIX flavors it's /etc/hosts).

  • I do not think it has anything to do with DNS to be honest. On the same computer, I used putty to access the server command line over ssh, and entering the .local address worked fine. Plus, on a win 10 computer I have, entering the .local address works on both. Aug 3, 2017 at 0:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .