1

So as a bit of background, I'm attempting to set up a Wake on Wan service for a specific device. The service isn't any issue, it works in its current form. The issue arises from the arp table/cache clearing out the MAC address of the device I'm attempting to reach after 15-20 minutes.

If i attempt to WoW between the time I put it to sleep and 15-20 minutes, it will wake up, but after it just sits in Sleep mode.

The instructions I've found regarding this task instruct me to telnet to 192.168.1.254(Default Gateway) so I can then add the arp entry, however, telnet seems to be disabled on this proprietary hardware. It is listed in a user manual here that telnet is possible on the hardware. Visiting the hardware management site by typing in 192.168.1.254 into a URL bar has no options in any menus to activate telnet. The error i get when attempting to telnet is:

Microsoft Telnet> o 192.168.1.254 Connecting To 192.168.1.254...Could not open connection to the host, on port 23: Connect failed Microsoft Telnet>

After that, i researched into downgrading the firmware on the router to allow a bypass of the system to allow telnet, but I could not find a version of firmware online that went back far enough to allow that. So, i guess that my question could be summed up as 'Is there a way i can connect to my router (NVG589) via telnet or other methods to allow me to enter a new static entry on its ARP table so Wake on Wan would work past that expiration mark'?

If there's any other information you need, let me know and I'll provide as best I can. If you need to know more about the WoW setup i have outside of what I've explained here, I can also do that. Thanks.

Edit: To clarify in the main post what I've discussed in the comments, I have port forwarding active, targeting my PC with NAT specific to what it needs to receive to Wake on Wan. I have also allowed inbound traffic via the Public Subnet options and disabled relevant firewall options and disabled all packet restrictions. With all of my current settings on the hardware management site(http://192.168.1.254), I can succeed at sending the Magic Packet remotely. The packet being sent to my router and forwarded to my PC is not an issue.

The issue becomes the Router is forgetting that my device even exists anymore, as the entry to the ARP table is flushed once a set amount of time passes with no activity from the PC(Which is the case since my PC is in Sleep mode for that time frame). Since the router no longer sees the PC as a existing device, even though it has port forwarding active to a device with address xxx.xxx.xxx.xxx, it has no entry in the ARP table associating that IP address with the MAC address of my PC.

0

I believe you are asking the wrong question.

To answer your question, the router is proprietary. The type of functionality you are asking for is likely not present and there is nothing you can do to change that.

The question you should be asking is, why does my wake on LAN require an ARP table at all?

ARP converts IP addresses to MAC addresses. Wake on LAN works at OSI layer 2. Or, in other words, it works with MAC addresses. A magic packet that wakes a computer should be directed at it's MAC address, not it's IP address. A computer does NOT have an IP address in standby. That is why the ARP entry disappears. So, the answer to this question is that you are using WOL improperly. You are just getting lucky it works at all because you have an ephemeral ARP entry assisting you.

If you want to WOL over the Internet you'll need some kind of proxy service to do it for you. WOL was specifically designed to be used between machines on the same local network.

Here is a good reference that will hopefully explain it better than I have: https://www.smallnetbuilder.com/lanwan/lanwan-howto/29941-how-to-wake-on-lan-wake-on-wan

https://en.m.wikipedia.org/wiki/Wake-on-LAN

  • Okay, i'm attempting to set up Wake on Wan, which is possible, as it works for a set amount of time. From what i understand relating to this, Wake on Wan will work as long as an entry exists on the ARP table regarding a specific device. I've enabled the device to have a static IP, but because the entry in the ARP table expires, the communication falls short. – Viiya Aug 3 '17 at 12:02
  • I did in fact read through that link during my mission to complete this task, but that article is from 2007 and while the information may still apply, nearly all other more recent sources i've found would say otherwise. link shows what I'm trying to attempt. – Viiya Aug 3 '17 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.