0

I have installed CentOS on the same disk before and booted with rEFInd no problem, but I didn't like CentOS too much since I couldn't easily port Ubuntu packages over and I wanted Ubuntu back, so I tried installing Ubuntu to replace CentOS, and this is my story.

I have been having a lot of trouble installing Ubuntu on my iMac. Apparently the kernel is working since rEFInd detects my Ubuntu installation, but when I go to boot I get this screen after a few seconds. Nothing does anything-- I've tried to just wait it out, since typing does nothing (doesn't even print anything on the screen), so I have no clue what to do here.

Specifications:

  • iMac 21.5" 64 bit compatible
  • Ubuntu x86_64 installation
  • Ubuntu disk is separate from macOS disk
  • rEFInd bootloader which works with every other OS (grub didn't work well with it, so I installed Ubuntu without a bootloader)
  • Installed on USB external drive since INTERNAL SATA DRIVE IS BROKEN.
  • Kernel detected, just leaves me at the black screen though.
  • I have reinstalled several times and got the same result
  • Typing does nothing
  • Escape key does nothing
  • ALT <-- then ALT --> (to switch tty) does nothing
  • No LVM
  • No full disk encryption
  • Mount points for a future web server and backups so that if I reinstall Ubuntu I can leave the Apache installation and backups alone; these being /var/www/ mounted as a LOGICAL partition, /backups/www-server/ mounted as a LOGICAL partition, and finally /etc/apache2/ mounted as another LOGICAL partition.
  • Installation root mounted as / is a PRIMARY partition.
  • No EFI partition
  • No GRUB partition
  • I honestly don't know what the partition map is, but I do know it is either GUID or Master Boot Record (MBR).

That's all the specs I can think of, tell me what you need to know if it isn't sufficient. Thank you for your time!

0

I fixed my own problem. What I did is I added a 1024 MB (not MiB) ext4 partition mounted at /boot at the BEGINNING of the disk. Then what I did is reinstalled and booted the iMac while holding option/alt to get the system bootloader. Then I booted (and made default by holding control and enter) rEFInd, and booted from there GRUB2, then inside grub booted Ubuntu. Doing it any other way does not work! Ubuntu booted up, and it worked. Rebooting and doing the same thing worked fine.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.