1

After updating to Windows 10 Education Build 15063 (The Creators Update), I have noticed that the bottom row of icons shift to the right on start up, requiring me to move them back into place by scaling the icons down (using CTRL+scroll wheel) and shifting them back over and then sizing them back up. Simply moving the icons over places them back into the original, and wrong position. As an example, see the pictures provided below:

Before: Normal Icon Placement

Normal Icons

After: Shifted Icon Placement

Incorrect Icon Placement

Please note: I have tried moving the icons back over, I have tried editing icon spacing in the registry, I have tried placing different icons in the bottom row and none of these yielded results.

Also note: This began happening after my update from the Anniversary Update to the Creators Update.

  • 1
    Right click on desktop click to enable/disable auto arrange icons – Biswapriyo Aug 3 '17 at 20:04
  • Scrambled my icons but no success. – Stephen Aug 4 '17 at 8:26
  • Try the option like "Align icons to grid" in that context menu. Also try to sort those icons by name/date. – Biswapriyo Aug 4 '17 at 13:45
  • Aligning to grid and arranging by name/date did not fix the issue – Stephen Aug 4 '17 at 18:35
  • I have similar issue, icons layout changes when 1) monitor scaling is changed or 2) taskbar autohide is enabled or 3) taskbar is moved to left vs bottom. Check if any of these options change your layout – Alec Istomin Aug 9 '17 at 5:30
1
+50

I had one user with this issue and this was what fixed it for us:

  1. Right-click on the desktop and click View
  2. Uncheck align icons to grid
  3. Right-click on your desktop and click View again
  4. Check align icons to grid

At this point I was able to place the icons in areas that had previously not allowed icons.

I've heard of others having success changing the icon size as well, and then changing it back.

Basically, it appears this is due to the icon alignment grid being confused, and what is enforced doesn't allow the icons to fit without colliding. By disabling and re-enabling the grid it allows Windows to re-figure the boundaries and make the icons fit correctly to the grid again.

1

You could try to force Windows to save the desktop icon positions manually as described here:

You can simply right-click the Desktop & click Refresh. This saves the icon positions.

But most probably you need a stronger antidote. I had the same issue with XP and Vista and used a small tool, called DesktopOK, to save and restore my icon layout as needed (you can have different layouts too!). It works fine with the latest version of Windows 10 (v1703 and current insider builds).

-1

Have you tried clearing the ItemPosXXXXX keys out this registry location? HKEY_USERS{USERID}\Software\Microsoft\Windows\Shell\Bags\1/Desktop/

  • 1
    Please provide a more detailed answer – Ramhound Sep 8 '17 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.