5

I build a dual monitor dashboard with Google Chrome (V. 60.0.3112.78) under CentOS 7. Everything is working with the exception that I am not able to disable Chrome's translation feature via the command line.

I already start Chrome with --disable-translate but Chrome asks still if it should translate the page or not.

  • There are 2 ways to do that (that I know of). The first one is through --disable-translate that you already tried and the second one is through the browser settings (Languages ....). Now why 1st one fails? if there's already another instance of Chrome running, running it from the command-line will ignore the switches passed in the command, so you won't be able to pass the --disable-translate switch. You'll need to close all instances first. – Jimmy_A Aug 4 '17 at 8:27
  • --disable-translate seems to be ignored on this computer by Chrome. Unfortunately I can't use the browser settings as there are multiple instances of Chrome are running, each with a temporary directory as home directory. – Oliver F. Aug 6 '17 at 8:18
5

After searching for a while I found out, that the --disable-translate flagt has been removed from Chrome.

The proposal to remove this flag is available online at https://groups.google.com/a/chromium.org/forum/#!topic/chromium-reviews/nOgks4a7_uI.

5

If you have control over the web content being displayed (it seems you do), you can place this meta tag in the <head> section:

<meta name="google" content="notranslate">

That will stop Chrome poping up the translation dialog.

Still if it's not your web page, you can install the ModHeader extension to modify the response headers yourself: https://chrome.google.com/webstore/detail/modheader/idgpnmonknjnojddfkpgkljpfnnfcklj

See also:

  • This is correct, unfortunately I don't have access to the source files. – Oliver F. Jul 20 '18 at 8:11
2

From https://bugs.chromium.org/p/chromium/issues/detail?id=770776#c11, you may add the following option(if you are using the latest version Chrome)

--disable-features=TranslateUI
1

As of chromium version 60.0.3112.89, --disable-translate doesn't work anymore.

The workaround, if you have access, is to remove the lang from html tag or set it to "en".

  • 1
    Why the hell did they remove it?!! – David D. Apr 28 '18 at 13:40
  • As of version 65.0.3325.181 this has erratic behaviour. – Miguel Pynto Jan 9 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.