0

I have a Win7-64 machine (using EFI boot) that was working OK, but has developed a boot loop. It reboots, enters Startup Repair, and fails with ExternalMedia, CorruptVolume.

I booted the Win7 install disk (straight-from-Microsoft Win7 Ultimate, using UEFI boot) and entered Repair. chkdsk -v -f c: finds no errors, but sfc /scannow refuses to run, saying that there's a repair pending.

I tried many of the dism recipes to rollback pending updates, etc., and the bcdboot and bootrec recipes for fixing the boot record. No change.

The disk itself appears to be OK: I made a clone using a disk-to-disk docking station, and the clone behaves exactly the same way as the original disk.

The user data appears to be OK, so I could just do a fresh install, install all the programs, and then copy the user data over, but that's a LOT of work. Is there any way to:

  1. Fix the boot loop enough that I can make an up-to-date system recovery image before a fresh install?

  2. Copy programs and user data (for several different users) from the broken-boot disk into a fresh install, without having to fix endless permissions problems?

  • 1
    You say that you have a W7 machine with EFI boot, single or multi boot? How did it develop that loop? No W7 machine can "develop" itself ;) There was an update, you made some changes or some new software made changes to system? – snayob Aug 5 '17 at 4:32
  • Single boot, the W7 install process picked EFI (I'm not very familiar with that boot method, although I know my Macs use it. But this is a standard Mini-ITX PC, Gigabyte F2A88X-Wifi, AMD A10-7850K CPU. It's a few years old and has been reasonably reliable.) I found the boot loop when I woke up one morning...I think it probably installed an update overnight which failed. I set the machine to only install updates when I explicitly say so, but I think it still does some installs or system changes or something on its own. I don't trust M$! – Dave M. Aug 5 '17 at 4:40
  • pending reboot means there is a pending.xml in winsxs. run DISM /image:C:\ /cleanup-image /revertpendingactions from cmd of repair options to revert all pending actions. now try to run sfc – magicandre1981 Aug 5 '17 at 6:43
  • That's one of the things I tried...I also looked in winsxs directly. There are ~18700 directories (apparently info about previously-applied updates?) and files Starter.xml and Ultimate.xml, but no directory or file named pending.xml. – Dave M. Aug 5 '17 at 15:17
  • Wait, sorry, Starter.xml and Ultimate.xml are in C:\Windows. In winsxs, there was reboot.xml. I renamed it and restarted, but it didn't make any difference. The Startup Repair process fails with EventName StartupRepairOffline, Signature01 6.1.7600.16385, Signature05 ExternalMedia, Signature06 15, Signature07 CorruptVolume – Dave M. Aug 5 '17 at 15:23
3

I tried a lot of things, mostly focusing on the boot record, but without any luck. I think many of the scripts and guides out there may be designed for MBR disks, but my system is using EFI, so it doesn't have, for example, C:\boot\BCD to delete and re-create. (I also tried EasyRecovery Essentials from NeoSmart, which is a FreeBSD-based automatic recovery boot disk. This booted properly, but the proprietary program that is supposed to find & fix things crashed with a SEGV. I will update this answer if NeoSmart support responds and provides help, but at the moment, I can't say anything good about this $19.75 "guaranteed fix." Update: tech support responded and provided a beta copy of their new version. It didn't crash, but it also didn't fix the disk (I had kept a clone of the broken disk, and it didn't fix it.) So: thumbs down on NeoSmart Easy Recovery.)

The thing that did help, though, was a post on answers.microsoft.com:

In my case, I'e booted the installation-DVD, Repair, Advances, Command Prompt.

Then I navigated to C:\Windows\System32\config.

There I've renamed ...

DEFAULT SAM SECURITY SOFTWARE SYSTEM

to *.old and copied the registry-hives from C:\Windows\System32\config\RegBack to C:\Windows\System32\config.

After this, I was able to boot, without loced drive, without Critical_Process_dies, etc.

After renaming and copying the registry backups as described, I was able to boot my system without a System Repair loop, and I am creating a system image to reconfigure a fresh install.

| improve this answer | |
  • ok, thanks for sharing the solution. next time notify me with @ my username in the comments, I haven't see that you replied to me. – magicandre1981 Aug 9 '17 at 15:20
  • what if after copying those 5 files from config\RegBack to config it gives the same error? @magicandre1981 – golimar Aug 16 '18 at 20:32
  • @golimar this is not my solution, so I have no idea. Add a bounty to the question, telling that the solution doesn't work and you need a 2nd answer. – magicandre1981 Aug 17 '18 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.