0

I have worked for two weeks on a file, and all went perfect, until today.

My system Mac OS 10.11.6 Excel 14.7.5

I've never had such issue before. I have created a huge file, and worked on it for two weeks, as I am learning excel. I did add a few interesting features there, and it all worked nicely. But today, after a whole day of working on it, I have saved it and closed it, and then tried to reopen and got a message that "Excel couldn't open the file because some content is unreadable. Do you want to open and repair?". After hitting Open and repair, I get the message that This workbook cannot be opened and repaired because it is corrupt. I am shocked to say the least. So much work done.

I don't understand what's happening. The only thing that gives me a little hope is that when I look in my directory, and put a mouse on a file, I see that it does display some content, sort of a picture. See screenshots. So I do hope the data and all formulas, formatting, etc is not lost. I save the file in both formats .xlsx and .xlsm (I have macros only on one sheet).

I will be grateful for your help!

Screenshot

  • Won't fix it all, but Time Machine ought to have a version within the last hour from the autosave. – Tetsujin Aug 5 '17 at 19:15
  • @Tetsujin My Time Machine is off. – Vitale Aug 5 '17 at 19:16
  • Then autosave itself might be your only hope - support.office.com/en-gb/article/… – Tetsujin Aug 5 '17 at 19:33
  • @Tetsujin No, this is not the way. There should be a way to recover a file. – Vitale Aug 5 '17 at 19:53
  • 'should be' vs 'is' does not actually equate. If you don't have backups, you have no recourse. – Tetsujin Aug 5 '17 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.