1

I'm trying to connect to a Server 2012 IIS 8 FTP server using FTP in the command line of another Windows client. As soon as I try to transfer a file or list the directory, it hangs indefinitely... no error messages or time outs, no errors in the log. I have full control over both client and servers but can't get it working.

I can ftp to localhost when I'm on the server, but not from any of the clients outside the network. I CAN ftp using Filezilla client, just not from FTP in the command line... which is what I need to do so using anything other than the command line FTP is not an option.

This was working at one point but then stopped. I don't know why. I am the only user on this system (development) and I do not remember doing anything with IIS when it stopped. However, I have applied a number of Windows patches.

I've tried everything I could find in web searches:

  • turned off the Windows firewall completely
  • enabled/disabled stateful ftp
  • configured passive ports in IIS and Firewall
  • allowed "Everyone" in file permissions and ftproot
  • Probably should have added that too. I've tried that and it doesn't change anything: 230 User logged in. ftp> quote pasv 227 Entering Passive Mode (104,238,116,112,160,40). 200 PORT command successful. 150 Opening ASCII mode data connection. – Velocedge Aug 6 '17 at 15:41
  • Yes, used bin when I tried to transfer a file. Actually, Filezilla works on Default, Active, and Passive with autodetect on character set. No SSL certificate is selected and SSL Policy is set to "Allow". I'm not aware of any settings that "allow insecure FTP". Nothing in the event logs or the FTP Log (other than the logons, no errors). – Velocedge Aug 6 '17 at 16:37
  • I'm out of ideas so it'd just be a guess any more. Give some time to see if anyone has any suggestions otherwise you might ask a moderator to migrate this over to serverfault.com so you do not have to cross post this can be moved over there. I've not done much FTP server administration with Windows IIS FTP functionality and always use other products that support SSH FTP easily and by default. Keep googling around and looking in logs and see if you can enabled verbose server and verbose client logs and consider Wireshark trace both client and server with and without issue and compare. – Pimp Juice IT Aug 6 '17 at 16:42
  • Appreciate the suggestions... I'll keep looking! – Velocedge Aug 6 '17 at 16:53
0

Would the moderator who deleted my answer please reconsider. The OP says they turned off the firewall completely - but they don't say on which machine. The obvious machine for turning off the firewall is the IIS server. I did this when trying to solve my own problem. It is NOT obvious (not to me, anyway) to turn off the firewall on the client. I still can't explain why I thought to try it. But that is what fixed this scenario for me. Oh, and yes of course I am not suggesting that the firewall stays off, it is just to identify the problem. So clearly there needs to be an outgoing FTP rule on the client firewall.

  • This should be a comment I believe. And what your original "Answer" should have been should also have been a comment. (I am not a mod) – El8dN8 Feb 10 '18 at 23:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.