1

I've installed Fedora 26 onto a system that has Windows 10 on it. I can boot into Fedora but now I can not boot into Windows 10.

I have entered into the grub/boot shell, and identified the Windows partition as (hd0,gpt3) as follows:

grub> ls -l

Partition hd0,gpt3: Filesystem type ntfs - Label 'OS', UUID ... - Partition start at 644096KiB - Total size 326339584KiB

I also see

Partition hd0,gpt1: Filesystem type fat - Label 'ESP', UUIS ... - Partition starts at 1024KiB - Total size 512000KiB

How can I boot into that partition from the grub shell?

How can I add a menu entry for that partition?

9
  • 1
    set root=(hd0,gpt1); chainloader EFI/Microsoft/Boot/bootmgfw.efi; boot; better use search -u UUID_OF_ESP -s instead of set root=(hd0,gpt1) when you form a menuentry in grub.cfg
    – Tom Yan
    Commented Aug 7, 2017 at 1:06
  • 1
    boot is not needed for a menuentry. booting via direct commands probably needs it, not exactly sure for the case of chainloader
    – Tom Yan
    Commented Aug 7, 2017 at 1:07
  • How come GRUB installation has not detected Windows? "update-grub2" should do.
    – snayob
    Commented Aug 7, 2017 at 2:40
  • @TomYan Thanks. I get error: invalid file name 'EFI/Microsoft/Boot/bootmgfw.efi'. Any idea? This is Windows 10 Professional if that makes any difference. Is there a command to find out what files exist in that partition?
    – isapir
    Commented Aug 7, 2017 at 4:56
  • @snayob That's a good question - I also expected it to detect Windows. I don't have a command update-grub2, nor grub2-update. I tried dnf reinstall grub2 and that didn't add such a command either. This is Fedora 26 KDE spinoff, if that makes a difference.
    – isapir
    Commented Aug 7, 2017 at 5:04

1 Answer 1

1

I have reinstalled Fedora and now I have Windows again in the boot menu. Things to pay attention to:

  • Booting with the USB installation medium plugged in had 2 different options: Legacy (BIOS) mode, and UEFI mode. As @TomYan pointed out, I must have selected the wrong mode initially, which caused this whole problem. I should have paid attention and selected to boot the USB in UEFI mode.

I created the following partitions, probably larger than needed but I have enough disk space so no issue there for me:

  /boot/efi     EFI System     256 MiB
  /boot         Ext4           768 MiB
  /             Ext4            56 GiB
  swap          Swap             8 GiB
1
  • 1
    For the benefit of others: Booting the installation medium in the wrong mode (typically BIOS rather than EFI) is a common mistake. When dual-booting with an existing EFI-mode installation of Windows, the common advice to enable BIOS/CSM/legacy support in the firmware is very bad advice that can lead to this trouble. There's less and less need for BIOS-mode boot support these days, so that support should generally be left disabled.
    – Rod Smith
    Commented Aug 8, 2017 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .