0

I ran rsync sudo rsync -aE --progress /mnt/seagate/dataset/RD\ 8* /mnt/backUp/backUp/dataset/ and pressed ctrl-c by mistake. There was a SIG-INT error whic makes sense. But now, I am not able to access the hard disk mounted on /mnt/backUp.

Whenver I try to access my drive, it says: This location could not be displayed. Sorry, could not display all the contents of “dataset”: Error when getting information for file '/mnt/backUp/backUp/dataset/RD 838Jun05': Input/output error

output of sudo ll is attached in the image below. output of sudo ll

I tried running : sudo smartctl -i /dev/sde2 whose output is

smartctl 6.2 2013-07-26 r3841 [x86_64-linux-4.2.0-42-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               Seagate
Product:              BUP BK
Revision:             0108
User Capacity:        4,000,787,029,504 bytes [4.00 TB]
Logical block size:   512 bytes
Physical block size:  4096 bytes
Lowest aligned LBA:   0
Logical block provisioning type unreported, LBPME=0, LBPRZ=0
Logical Unit id:      0x3e41375436453851
Serial number:        NA7T6E8Q
Device type:          disk
Local Time is:        Sun Aug  6 16:55:06 2017 EDT
SMART support is:     Unavailable - device lacks SMART capability.

Can you please tell me if there is any way I could fix this? I am not able to do ntfs-fix as well

  • I doubt it is a problem with the hard drive. See if you have any process in "device sleep" Sz (I think is the indicator, when you run ps). Try remounting the drive, and, perhaps, reporting the bug to whoever supplied the driver / perhaps even to the Linux Kernel people (but check if this isn't a known issue first). – wvxvw Aug 7 '17 at 8:05
  • @wvxvw I tried remounting the drive, even on different computers and it gives me the same error. – deeplearning Aug 7 '17 at 10:27
  • Can you try running fsck on it? Maybe the filesystem got damaged somehow. hm... – wvxvw Aug 7 '17 at 18:32
0

I was able to recover my old data by scanning and repairing my disk using Windows OS. You have to right click on your device detected in "My Computer", go to Properties-->Tools and click Scan. It will eventually report errors if any and you can repair them. I was able to remount it in Linux later without an issue.

As quoted from howtogeek" Chkdsk can also optionally scan every sector on a disk volume looking for bad sectors. Bad sectors come in two forms: soft bad sectors, that can occur when data is written badly, and hard bad sectors that can occur because of physical damage to the disk. Chkdsk attempts to fix these problems by repairing soft bad sectors, and marking hard bad sectors so they won’t be used again.

"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.