2

I have a Sony Vaio vpceb1jfx and its quite old. Suddenly the touchpad went crazy and started clicking and moving around constantly.

I tried everything to make it stop, but I couldn't. I have formatted it several times and tried everything.

Now, I ended opening the notebook and unplugging the cable that connects the touchpad to the motherboard. Hoping that the mousepad would stop and I could control the pointer with an usb mouse.

But what happens is the computer not detecting the USB mouse at all (or is it? it doesn't even show a message when plugging or unplugging). I have windows 8.1 now.

In the device manager, under "mice and other pointing devices" it shows some kind of touchpad driver, but is in yellow sign and not working. (says it is not present)

It is strictly necessary to have the touchpad connected to move the pointer? even with an usb mouse? Or the problem is with the usb mouse? I've installed the motherboard drivers. And the touchpad drivers too. Maybe is there a way to "emulate" a mouse device, and control it with the usb mouse?

It's a complicated problem, but any help would be appreciated.

1

The touchpad is not required to be hooked up for another mouse to work. Double check that the cable you unplugged is strictly for the touchpad and not running to any other controller boards that might handle USB ports. Also make sure you didn't accidentally unplug any other cables inside the laptop that might run to the USB ports.

As with any USB device, if you plug/unplug it you should hear a noise from Windows indicating so. If you don't hear anything, please try another USB port or another device in that USB port to see how it responds.

It sounds like the touchpad has gone bad on your laptop. Disconnecting is probably the best thing to do. The issue with the external mouse not working is a separate issue. Please troubleshoot that by making sure the mouse works on another PC or test different USB ports, etc.

  • The mouse works on My other pcs. The usb ports are working fine I think. (I can connect usb mass storage without a problem). Sometimes it makes the sound of usb connected, and shows me the "device not rrcognized or not working" sign. – user3517178 Aug 7 '17 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.