0

I have that entry in my fstab which works pretty well when I'm at home and 192.168.1.195 is in my LAN

# https://wiki.archlinux.org/index.php/NFS#Mount_using_.2Fetc.2Ffstab_with_systemd
192.168.1.195:/media/drive3/calibre    /home/user/calibre    nfs     rw,noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min  0       0

Now when I'm not connected at home, on another network, I face that issue launching deluge-gtk where it takes ages to launch and outputs that error message

➜  ~ deluge-gtk
invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.vfs.UDisks2VolumeMonitor:: Timeout was reached (g-io-error-quark, 24)

If I comment the fstab entry, then deluge-gtk launches absolutely fine and don't get that message.

What can I do in order to solve that issue, is there a param in /etc/fstab i could add to detect I'm not at home ?

2

The problem using the /etc/fstab file is that the mountpoint is mounted always and if not reacheable, it can hang your machine because the kernel will continuously try to mount the point.

To avoid this, you could use autofs (/etc/auto.master), which is a kernel-based automounter. In that case, the mountpoint will only be mounted if you (or some process) access the configured directory, and if you don't, or the mountpoint is idle for some time, it will automatically be unmounted and this way you can avoid the the hanging behavior.

I believe not all operating systems have the autofs package installed by default. You can check if it's installed and if not, install the autofs package. Once installed, simply run man autofs to get some help.

You can find additional info on this here:

2
  • There's something I don't get with your explanation but maybe I'm mixing things, you say the the mountpoint is mounted always, but I thought the noauto mount option was there exactly for that case, it will not mount the NFS share until it is accessed. – euri10 Aug 7 '17 at 20:36
  • noauto will not mount the mountpoint automatically, but you'll need to mount it manually instead (for example, running mount /bla). In that case, the mount information will be extracted from the /etc/fstab file and the kernel will try to mount it, but it doesn't mean the mountpoint will be mounted each time it's accessed; you can get this behavior with autofs instead. – nKn Aug 8 '17 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.