I have been trying to capture an image of a Windows 10 Pro x64. I get the error message Sysprep was not able to validate Windows Installation and a report with errors as pasted below. I have about 20 Surfaces 4 Pro to deploy the image to.

The errors:

2017-08-08 12:38:35, Error SYSPRP Package 89006A2E.AutodeskSketchBook_1.5.2.0_x64__tf1gferkr813w was installed for a user, but not provisioned for all users. This package will not function properly in the sysprep image.

2017-08-08 12:38:35, Error SYSPRP Failed to remove apps for the current user: 0x80073cf2.

2017-08-08 12:38:35, Error SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.

2017-08-08 12:38:35, Error [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'SysprepGeneralizeValidate' from C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2

2017-08-08 12:38:35, Error SYSPRP SysprepSession::Validate: Error in validating actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2

2017-08-08 12:38:35, Error SYSPRP RunPlatformActions:Failed while validating SysprepSession actions; dwRet = 0x3cf2

2017-08-08 12:38:35, Error [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x3cf2

2017-08-08 12:38:35, Error [0x0f00d8] SYSPRP WinMain:Hit failure while pre-validate sysprep generalize internal providers; hr = 0x80073cf2

  • Try opening a command prompt (or PowerShell) window and execute slmgr /dlv. Within the ensuing window, check the Remaining Windows rearm count to ensure that it says at least 1
    – Run5k
    Aug 8, 2017 at 17:20
  • @Run5k I checked and it indicates 1001.
    – AnsBekk
    Aug 8, 2017 at 17:25
  • What command did you run exactly? What user are you using? If you are using something other than the built-in account that could be a problem.
    – Ramhound
    Aug 8, 2017 at 18:27

3 Answers 3


The first line of that error log is the key. Microsoft has a support article describing this problem. First, you need to uninstall the Universal Windows Platform app mentioned in the error. To do that, search for it in the Start menu (it's probably called something along the lines of "Autodesk SketchBook"), and if it's found, right-click it and choose Uninstall. Reboot, and try to run Sysprep again.

If that doesn't help, run this command in an elevated PowerShell prompt:

Get-AppxPackage -AllUsers | ? {$_.PackageFullName -eq '89006A2E.AutodeskSketchBook_1.5.2.0_x64__tf1gferkr813w'}

Look at the PackageUserInformation property. If any users have the package Installed, destroy the user account if it is not needed, otherwise log in as the user and uninstall it. If you can't do that, use this command to remove the package for all users:

Remove-AppxPackage -Package '89006A2E.AutodeskSketchBook_1.5.2.0_x64__tf1gferkr813w' -AllUsers

Reboot and try again.

If Sysprep still refuses to continue, you need to unprovision the package (that Microsoft article says that Sysprep "will also fail if an all-user package that's provisioned into the image was updated by one of the users on this reference computer"):

Remove-AppxProvisionedPackage -Online -PackageName '89006A2E.AutodeskSketchBook_1.5.2.0_x64__tf1gferkr813w'

You might also check the log file again if the failure remains - Sysprep might start complaining about a different package that also needs to be removed.

  • Thank you for your reply. I greatly appreciate it. The problem when i run this command, i see a user that i cannot use it as an account to login. The package user information is: {s-1-5-21-1968875819-78012282-1250455498-1001 [s-1-5-21-1968875819-78012282-1250455498-1001]: Installed} What do you think? I also tried to unprovision using the command provided, not working!
    – AnsBekk
    Aug 10, 2017 at 14:14
  • Hmm, that's interesting. How exactly does the unprovisioning command fail? (If the error message won't fit in a comment, you can edit it into the question.)
    – Ben N
    Aug 10, 2017 at 14:15
  • @AnsBekk You might want to try the unprovisioning command with the -AllUsers switch added. Also try Remove-AppxPackage -Package '89006A2E.AutodeskSketchBook_1.5.2.0_x64__tf1gferkr813w' -AllUsers.
    – Ben N
    Aug 10, 2017 at 14:23
  • Remove-AppxProvisionedPackage : The system cannot find the file specified. At line:1 char:1 + Remove-AppxProvisionedPackage -Online -PackageName '89006A2E.Autodesk ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Remove-AppxProvisionedPackage], COMException + FullyQualifiedErrorId : Microsoft.Dism.Commands.RemoveAppxProvisionedPackageCommand
    – AnsBekk
    Aug 10, 2017 at 14:27
  • I will try what you just suggested
    – AnsBekk
    Aug 10, 2017 at 14:27

Here is how i solved this issue,

I have deployed fresh windows 10 build 1709,


This worked for me. Get-AppxPackage -AllUser | Where PackageFullName -eq 89006A2E.AutodeskSketchBook_1.8.1.0_x64__tf1gferkr813w| Remove-AppxPackage -AllUsers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .