5

Ever since updating to Firefox 55, typing in the address bar brings up an annoying "Search with Google" option at the bottom of the address bar.

When I type something, this happens:

When I type something, this happens

In Options > Search, I have removed as many search engines as possible, under the One-click Search Engines. The last one, be it Google or something else, is not removable.

This is my Options > Search menu: This is my Options > Search menu

The Default Search Engine drop-down list only contains Google.

This renders the use of Firefox 55 an extreme annoyance since I have my address bar configured to give me my bookmarks only.

I would like to know how to remove every single search engine from Firefox 55.

ADDENDUM

I am using a sixty-four bit Firefox installation. The path C:\Program Files\Mozilla Firefox\browser contains not the "searchplugins" folder.

4

As far as I know you can't remove all search engines or at least it makes no sense for you because you can fix you problem without removing all search engines.

How to remove the unwanted search entry in the drop-down menu:

  1. Go to about:preferences#search
  2. Uncheck Provide search suggestions
  3. Under One-Click Search Engines remove the blue tick symbol for every search engine.

Now it should look like this:

Example1

  1. Open about:config
  2. Click on I accept the risk!
  3. Search for keyword
  4. Change the value of keyword.enabled to false by double-clicking on it

Now it should look like this:

Example2

  1. Now your problem should be fixed

Note: Your Firefox will look a bit different than mine because I use Firefox Nightly.
Sorry for that.

  • 1
    This settings add this line user_pref("browser.search.hiddenOneOffs", "Google,Yahoo,Bing,Amazon.com,DuckDuckGo,Twitter,Wikipedia (en)"); in prefs.js firefox user folder. – Biswapriyo Aug 9 '17 at 14:57
11

To hide "Search for ... with:" box from the bottom of address bar autocomplete list, go to about:config and set browser.urlbar.oneOffSearches to false.

  • This is the correct trick to get back to Firefox 54 address bar - UI wise, without losing the different search engines (you can still use them if you set some keywords). This should be the accepted answer. – Otiel Aug 18 '17 at 8:57
0

Simply removing the blue tick symbol for every search engine from One-Click Search Engines did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.