2

Using Chrome I can go to gmail.com and log into my account no problem. (Update: I'm actually not sure of this. I've been logged into Gmail for a long time and don't want to log out to discover that I can't get back in.)

With Firefox 54.0.1 and IE 11, however, after clicking 'sign in' I'm sent to https://accounts.google.com/signin/v2/sl/pwd?continue=https%3A%2F%2Fmail.google.com%2Fmail%2F&service=mail&sacu=1&rip=1&flowName=GlifWebSignIn&flowEntry=ServiceLogin&cid=1&navigationDirection=forward where I enter my email address, click "Next" and then nothing. The button image changes, indicating that the click occurred, but then the page doesn't change at all. I am unable to get past this step.

I tried creating a brand new Firefox profile, with zero add-ons of course, and same story.

I've tried Edge 40.15063.0.0 and it's somewhat similar. When I click 'sign in' and am taken to https://accounts.google.com/ServiceLogin/signinchooser?service=mail&passive=true&rm=false&continue=https%3A%2F%2Fmail.google.com%2Fmail%2F&ss=1&scc=1&ltmpl=default&ltmplcache=2&emr=1&osid=1&flowName=GlifWebSignIn&flowEntry=ServiceLogin I'm presented two different accounts to choose from as well as "Use another account." (I'm thinking that maybe I was able to successfully sign into Google using Edge in the past.) Clicking any one of those 3 does nothing.

I've tried at the office and at home and at another person's home and same problem.

I've disabled Norton's smart firewall and auto-protect, to no avail.

Rather than going to gmail.com I've tried going to google.com and clicking 'sign in' from there, but the exact same thing happens.

I'm running Windows 10 Pro and am completely baffled. Any suggestions?

Update: On a lark I tried the Tor browser. It worked! Interestingly, and no idea if this is related, in Chrome my control icons aren't there (see picture). They work, and the tooltips are there, but the icons are missing.

Chrome vs Tor in gmail comparison

Update: I installed Opera and it does not work, so as far as I can tell, the only thing that works is Tor. I also changed Firefox's proxy setting to "no proxy" and that didn't help.

I also tried logging in with Firefox with the Dev Console open. I got Loading failed for the <script> with source “https://ssl.gstatic.com/accounts/o/971028622-postmessagerelay.js and Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified and Content Security Policy: Ignoring “'unsafe-inline'” within script-src: ‘strict-dynamic’ specified when the page loaded, but nothing when clicking "Next". FWIW, Tor give me the last two but not the first one.

  • 2
    This a personal or corporate machine ? – Ramhound Aug 8 '17 at 20:01
  • Corporate, although I don't see the distinction. I'm not using a VPN and there's no 'corporate-specific' software installed on the machine. – Mark Cramer Aug 8 '17 at 21:39
  • 2
    By the way I experience the exact samething behind a proxy at work. So given that, and my experience, it's relevant your using a corporate machine – Ramhound Aug 8 '17 at 22:01
  • "I've tried at the office and at home and at another person's home and same problem." I've tried again at home and it fails. On another computer at home, however, it works, so it appears to be machine-specific. – Mark Cramer Aug 10 '17 at 0:37
  • 1
    If you or a previous user edited the hosts file, you can get strange behavior from websites. – Christopher Hostage Aug 11 '17 at 0:27
2

The hosts file can cause strange behavior with websites, and any other software that has to access the network. Each OS has a different location for it, and different rules for accessing / modifying it, but here is a good reference for modifying your hosts file : https://support.rackspace.com/how-to/modify-your-hosts-file/ . Different programs may or may not use the hosts file, and may or may not reload the hosts file until restarting the program. If you have shared PCs, then it's a good rule NOT to edit the hosts file because it gets confusing.

|improve this answer|||||
2

Been struggling with this for the past hour. Turns out i had an entry in the hosts file for ssl.gstatic.com routing to 127.0.0.1. I put this in a while back to resolve an outlook 2013 issue where if people sent documents from google drive, it would freeze because of the way google sends the link. After deleting the entry and doing ipconfig /flushdns, signing in to google works.

|improve this answer|||||
2

Yay, this multi-year problem is now fixed, thanks to the hosts file edit. I had a workaround to block the chrome address from javascript in Chrome but no go in Edge. Getting rid of the gstatic entry in the hosts file fixed it! And will later figure out if still need to deal with the problem gstatic fixed, namely to stop Outlook 2016 hangs with Google doc file links.

For those that need instructions, the hosts file on my Windows 10 64-bit PC is in C:\Windows\System32\drivers\etc, but you can't edit it there. Copy it to say D:\ and add a .txt extension (so the file name becomes hosts.txt), then edit it. You need to put a # in front of any lines you don't want to be active, or just delete them. Mine looks like the below now, just so I remember when next I am back here!

# to stop Outlook hangs with Google doc file links
# turns out this makes Google sign in process fail. Oooops!!!
# 127.0.0.1 ssl.gstatic.com

So, just changing the hosts file and closing and reopening the browser was enough to let me log in OK.

|improve this answer|||||
0

I had a very similar problem at my workplace for the last couple of days. I couldn't sign it to a Google account (from Gmail and YouTube) as buttons were nonresponsive, and some buttons and icons disappeared in Google Translate.

I tried clearing cache, signing in with Incognito Mode, signing in with other browsers and from another computer in the same network. Nothing worked. I checked the hosts.txt and the settings of the router but there was nothing special there.

Finally, what's solved the problem was... turning off and on again the WiFi router.

|improve this answer|||||

Not the answer you're looking for?Browse other questions tagged or ask your own question.