3

EDIT: The problem fixed itself with the new Fedora 27 update.

Disclaimer: I tried asking this question on ask Fedora, but could never login due to an internal server error.

I upgraded from Fedora 25 to Fedora 26 last night, and since then I haven't been able to get wifi working.

I have installed the latest rpm fusion nonfree, and installed akmod-wl, but no luck. When I updated I got a warning about two incompatible packages that would be removed during installation. One of them was MySQL Workbench, and the other I'm not sure, but I think it may have been akmod-wl.

This is the lspci output for my wireless card:

07:00.0 Network controller: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe

Running ifconfig reports 3 interfaces:

$ ifconfig
enp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.65  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2806:105e:4:be65:ed82:5646:cd48:f5bf  prefixlen 64  scopeid 0x0<global>
        inet6 fdf4:dcf9:823a:7a00:95a2:28d3:a2b8:ee7b  prefixlen 64  scopeid 0x0<global>
        inet6 2806:105e:4:be65::2  prefixlen 128  scopeid 0x0<global>
        inet6 fe80::4da4:f2e9:b18c:dafd  prefixlen 64  scopeid 0x20<link>
        ether 78:e3:b5:62:40:56  txqueuelen 1000  (Ethernet)
        RX packets 1448  bytes 570458 (557.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1881  bytes 279806 (273.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 36  bytes 3124 (3.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 36  bytes 3124 (3.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:bc:d3:e3  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ip address reports wlo1 as down:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 78:e3:b5:62:40:56 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.65/24 brd 192.168.1.255 scope global dynamic enp1s0
       valid_lft 85212sec preferred_lft 85212sec
    inet6 2806:105e:4:be65::2/128 scope global dynamic 
       valid_lft 6015sec preferred_lft 2415sec
    inet6 fdf4:dcf9:823a:7a00:95a2:28d3:a2b8:ee7b/64 scope global noprefixroute dynamic 
       valid_lft 7030sec preferred_lft 3430sec
    inet6 2806:105e:4:be65:ed82:5646:cd48:f5bf/64 scope global noprefixroute dynamic 
       valid_lft 7030sec preferred_lft 3430sec
    inet6 fe80::4da4:f2e9:b18c:dafd/64 scope link 
       valid_lft forever preferred_lft forever
3: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 60:d8:19:8b:37:3a brd ff:ff:ff:ff:ff:ff
4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 52:54:00:bc:d3:e3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
5: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 1000
    link/ether 52:54:00:bc:d3:e3 brd ff:ff:ff:ff:ff:ff

Any idea what I can do to get wifi working again? Before the update to Fedora 26 wifi worked without problems.

  • Same here with a usb dongle. driver says it installed yet when I go to the Network under Settings, it doesn't give me a wireless option, just Wired. I unplug it and hope to see it come back but no dice. Did you get it up? – pjammer Aug 16 '17 at 9:34
  • Nope, I haven't tried since. I ran a cat 5 cord from the router to the other side of the room to my computer, and haven't tried anything else since. I installed an update today, and was hopping that would help but it did not. Any luck on your end? – Buzu Aug 21 '17 at 23:31
  • Nope. I installed it by returning all of the equipment i bought. I was using the edimax and tp-link dongles without any luck. 10 years of monkeying around and still wifi is the worst on linux. – pjammer Aug 22 '17 at 10:45
  • And no one seems to know how to fix this issue. – Buzu Aug 22 '17 at 22:47
  • Rather than editing the question, you should create an answer saying that F27 resolved the issue, and then accept it. – mattdm Nov 27 '17 at 21:19
1

Fedora 27 fixed the problem. Still not sure what was the root of it.

0

Run this codes on your terminal that's if you already have git installed, to clone the repo and kick of the automatic install script:

git clone https://github.com/FreedomBen/rtl8188ce-linux-driver.git && cd rtl8188ce-linux-driver && ./install.s

This should fix your Wifi Drivers issue

Source: GitHub

  • Thanks. I will try this out later and report back the results – Buzu Sep 4 '17 at 15:16
  • I tried it, and the build process fails every time [*] The build has failed! Please make sure you have all dependencies installed and you are building on the correct branch (kernel version, not linux distro version, is most important for the branch) – Buzu Sep 4 '17 at 16:19
  • By the way, when install.sh first runs, it says it wasn't able to find a Realtek card on my machine. – Buzu Sep 4 '17 at 16:21
  • That's because the github link he pasted offer drivers for the below models of wifi network cards, not "RT5390" as you stated in your question. RTL8188CE/RTL8192CE RTL8191SE/RTL8192SE RTL8192DE RTL8723AE RTL8188EE – AnythingIsFine May 5 '18 at 15:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.