3

While editing Documents in Word or typing Mails in Outlook or Chatting in Skype, I sometimes see a strange behavior in copy-paste.

Say I have the text " assign" in the clipboard, and put the cursor before the word "while". Now when I paste, I would expect either of these:

" assignwhile", where there is no space between the two words. This is normal and WYSIWYG.
" assign while", where an extra space between the words in automatically inserted by the application. This is some enhancement in the application to automatically put spaces where required.

But I get this:

" assignw hile", which has an automatic space, but shifted to the right.

I have seen this strange behavior for quite some time, and usually ignored it; Now I am able to undo-redo and see it consistently, hence asking here:
What is going on ?
If this is a feature, not a bug, then how to disable it ?

Environment:

Windows 10 Enterprise Version 1511 with Word 2016 Version 16.0.4549.1000

UPDATE:
In Outlook, while composing a mail, I had the text "we store" with " may" in clipboard.
When I Paste between "we" and " store", I get "we may store" [[ Correct ]]
When I Paste between "we " and "store", I get "we mays tore" [[ Wrong ]]
I tried it repeatedly with same results.

I tried pasting in Notepad, where I got the correct output, but strangely, "undo" or "ctrl-z" does not remove the Pasted text !
It only selects the Pasted text ! Paste inserts " may", undo selects " may" !

I then went to PowerShell and collected some Debug Data about the clipboard, using "Get-Clipboard -TextFormatType [[Html,Rtf,Text,UnicodeText]]".
Output was huge for Html+Rtf; I have uploaded all to pastebin :
https://pastebin.com/CZUbhfST

8
  • When you do the same thing in notepad - does it behave the same way or is it specific only for Word / Outlook. Have you observed similar behaviour in other office apps like Excel / Powerpoint? One can rule out this as an OS issue if the behaviour is consistent across apps - if not it could be something wrong with the MS Office application
    – Prasanna
    Aug 9, 2017 at 9:40
  • @Prasanna , I have seen only with Office applications, including Skype; Notepad, Putty all working fine.
    – Prem
    Aug 9, 2017 at 9:57
  • I'm wondering if this could be a clipboard issue. Are you open to trying other clipboard managers to see if this issue persists?
    – Prasanna
    Aug 9, 2017 at 11:21
  • @Prasanna , I am using only the built in clipboard, but it is unlikely to be the culprit , because it can not change the text in the target application. If copy-paste gave some wrong characters or it gave same behaviour in all applications , then clipboard may be a suspect.
    – Prem
    Aug 9, 2017 at 15:31
  • 1
    Could it be because of the smart feature called "Adjust sentence and word spacing automatically" (support.microsoft.com/en-us/office/…)?
    – djhurio
    Jul 29, 2022 at 13:24

1 Answer 1

1

Credit belongs to @djhurio!

This worked for me. From Microsoft Outlook 2016: File -> Options

enter image description here

enter image description here

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .